2

I recently sent my laptop to service and I believe they changed the motherboard. Before that I could get 1000mbps, but now the connection is stuck at 100mbps as you can see in the screenshot:

Adapter properties

The router and the cable remained the same. I tried 2 different versions of drivers, including the last one on the realtek website. I performed a clean install of the windows, the speed won't budge.

EDIT: The laptop is an ASUS GL752VW

I know that most people think it's the cable since that solved the issue in other similar questions, but I tried other cables and the problem persists and as I said, I had 1gbps connection before I sent my laptop to service with the very same cable I use now.

  • Hello and welcome to SuperUser. What is your question? – Marek Rost Jan 6 '18 at 15:52
  • 1
    Hello, I just want my NIC to be able to go up to 1000 mbps since it is my internet speed, but it won't go upper than 100 mbps for some reason. I just want to know if I should send the laptop back to service or there are some faster options I have regarding the problem. – Boanta Ionut Jan 6 '18 at 16:10
  • 1
    the laptop model i quite new, it's a gaming asus rog with gen 6 cpu. I checked under ethernet properties and at speed and duplex it is selected 1.0 gbps full duplex, so the NIC is compatible. It just doesn't want to work properly. – Boanta Ionut Jan 6 '18 at 16:40
  • 3
    Possible duplicate of Realtek NIC running at 100Mb/s rather than 1000Mb/s – Jason Bristol Jan 6 '18 at 18:58
  • 1
    Cables, cable,s cables! I have a bad cable right now doing the same thing; different hardware though. I usually start with the cables, then move onto troubleshooting other stuff if the cable checks out. – Damon Jan 7 '18 at 5:09
0

I too had similar issues... connect PC to modem and I get 1GBPS, connect through router (tried 2 different kinds) and get 100Mbps. With all the plugging in and out, the PC suddenly registered 1Gbps. So to anyone who is going through this. I really suggest not only swapping cables... but plugging in-out a few times, maybe even make sure there is no dirt in the socket etc.. because cables that consistently gave me 100mbps suddenly gave me 1 gbps. also I had a situation where a particular cable went from 1 Gbps to suddenly dropping to 100mbps...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.