9

I noticed that Micrsoft Edge was missing the taskbar icon, and then noticed all UWP apps are missing their icons. You can see this clearly in this screenshot of the lock screen settings:

Image on Lock screen settings with fallback icon

Things tried:

  • Tried repairing Windows using DISM.exe /Online /Cleanup-image /Restorehealth and sfc /scannow, but they didn't find any problems.
  • Reinstalling Edge with the following command didn't help either: Get-AppXPackage -AllUsers -Name Microsoft.MicrosoftEdge | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml” -verbose}
  • updating my graphics drivers to no avail.
  • chkdsk C: /f /r /x
  • Get-AppxPackage | Remove-AppxPackage then reboot and follow with Get-AppxPackage -allusers | foreach {Add-AppxPackage -register "$($_.InstallLocation)\appxmanifest.xml" -DisableDevelopmentMode} and reboot again.
  • Try and delete %AppData%..\Local\IconCache.db then restart.
  • Rebuild a Broken Icon Cache in Windows 10 - "To rebuild the icon cache, you have to delete all the iconcache files that appear in this folder": \AppData\Local\Microsoft\Windows\Explorer

Any idea what the problem might be, or suggestions on how to get the icons back?

Windows 10 Pro, 1709; OS Build 16299.192.

  • do repair install with 1709 ISO – magicandre1981 Jan 7 '18 at 17:36
  • @magicandre1981 Unfortunately this did not work: i.stack.imgur.com/jjHaw.png – Louis Jan 13 '18 at 4:14
  • Try to uninstall all apps in Powershell as Administrator: Get-AppxPackage | Remove-AppxPackage then reboot and follow with Get-AppxPackage -allusers | foreach {Add-AppxPackage -register "$($_.InstallLocation)\appxmanifest.xml" -DisableDevelopmentMode} and reboot again. – harrymc Jan 13 '18 at 11:36
  • wired. try those powershell commands to reinstall the apps. but since 1607 they caused more issues compared to what they fix. – magicandre1981 Jan 13 '18 at 12:08
  • A long shot: Try to Rebuild a Broken Icon Cache in Windows 10. – harrymc Jan 13 '18 at 14:11
4
+250

From Windows Explorer in the address bar, copy in the path ‪C:\Program Files\WindowsApps and then press Enter.

enter image description here

You'll likely get a pop up window telling you that You don't currently have permission to access this folder so you'll press the Continue option.

enter image description here

You'll then likely get a pop up window telling you that You have been denied permission to access this folder where there will be a link called security tab which you will click on.

enter image description here

From there the WindowsApps Properties window will open and from the Security tab you will select the Advanced option.

enter image description here

You will then press the Change option from the Advanced Security Settings~ window

enter image description here

You will then type in the username of the account you want to take ownership of the folder, press Check Name and then OK. Press OK again another time or two and then close any of the pop up windows from there that opened during this process.

enter image description here

Lastly, you should locate a folder with images/assets for the icons of an image file or two, right click the file and then select Open With option and then choose the Paint 3D app, or try various other programs until you see thumbnails being generated. The icons will mostly be back at this point and waiting, perhaps for the indexer and should eventually restore all icons everywhere.

enter image description here

  • @RicardoAmaral Oh.... try running icacls "C:\Program Files\WindowsApps" /reset /T and see if that resolves the problem. You might reboot afterwards but give that a quick try. – Pimp Juice IT Mar 23 '18 at 16:52
  • @PimpJuiceIT Unfortunately no, I don't have a backup. – Ricardo Amaral Mar 23 '18 at 18:20
4

Give one or both (in order) of the two solutions I quoted below a try to resolve your problem as you describe based on the other things you've already tried and eliminated.

  1. Complete the Repair the corrupt user profile registry key process first and then reboot, sign back on and see if the problem persists.
  2. If #1 alone doesn't resolve the problem then complete the Reset Windows 10 process as described below.

Repair the corrupt user profile registry key

Step 1. Open the Windows 10 Registry Editor by typing regedit in the Search box.

Step 2. When Registry Editor launches, navigate to the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList.

Step 3. Click each S-1-5 folder and double-click the ProfileImagePath entry to find out which user account it relates to. (If your folder name ends with .bak or .ba follow Microsoft’s instructions to rename them).

enter image description here

Step 4. Once you have determined where is the corrupt user profile(and it doesn’t have a .bak ending), double-click RefCount and change the Value data to 0 and click OK. If this value isn’t available, you might have to create it manually.

Step 5. Now double-click on State, make sure the Value data is again 0 and click OK.

enter image description here

Step 6. Close Registry Editor and restart your PC.


Reset Windows 10

Step 1. Open the Settings app by pressing Windows + I keys at the same time. Click Update & security.

Step 2. On the left pane, Click Recovery. Among the three options, choose Reset this PC.

enter image description here

Step 3. Click Get started under Reset this PC.

Step 4. Click either "Keep my files" or "Remove everything" depending on whether you want to keep your data files intact. Either way, all of your settings will return to their defaults and apps will be uninstalled.

enter image description here

Step 5. Select "Just remove my files" or "Remove files and clean the drive" if you chose to "remove everything" in the prior step. Cleaning the drive takes a lot longer but will make sure that, if you are giving the computer away, the next person will have a hard time recovering your erased files. If you are keeping the computer, choose "Just remove my files."

enter image description here

Step 6. Click Next if Windows warns you that you won't be able to roll back to a prior version of the OS.

Step 7. Click Reset if prompted.

source

  • @Louis From admin elevated cmd prompt, try running the these two commands 1. CD /D "C:\Program Files" & then 2. icacls WindowsApps /T /Q /C /RESET. See if that resolves & maybe reboot after the change & then retry. See icacls /? but you'll see replaces ACLs with default inherited ACLs for all matching files. in the section showing ICACLS name /reset [/T] [/C] [/L] [/Q]. Make sure you have good backups since you are trying many things here but let me know if that helps per the reset of the NTFS defaults there—I would think the above reset would've done it too. – Pimp Juice IT Jan 17 '18 at 3:13
  • This didn't work, but forcing me to take ownership of WinApps showed me that Explorer was unable to render any thumbnails for the PNG images/assets for any app. By doing Open with... and changing the default to Paint 3D instead of Photos seemed to force Windows to rebuild the thumbnails, and now I can see the icons again. But things are still a little broken: i.imgur.com/EvrWNKj.png The Remote Desktop icon has a solid black background, and I think the lock screen is not previewing correctly. Progress though! – Louis Jan 17 '18 at 3:41
  • Actually Photos was the correct app. For some reason forcing Paint 3D caused the thumbnails to slowly regenerate. I didn't get a chance to try this since everything has now sorted itself out. If you want to add another answer it would be: take ownership of WinApps; locate a folder with images/assets for the icons of an app or two; open-with: choose Paint 3D, or try various programs until you see thumbnails being generated; the icons will mostly be back at this point and waiting, perhaps for the indexer, will eventually restore all icons everywhere. – Louis Jan 18 '18 at 4:47
4

Google Drive File Stream was/is the culprit for me. Uninstalling this app brings the icons back. I don't have the option of removing the app so I live with this fix until I get Windows reinstalled and the dice gets rolled to see if the problem comes back.

What can temporarily work (day by day) is by removing the following Registry Key:

HKEY_CLASSES_ROOT.png\shellex{E357FCCD-A995-4576-B01F-234630154E96}

And then restarting Windows Explorer from the Task Manager.

This registry key will come back so when your icons disappear again you will need to do this again. This works for all of the icons except the Windows Mail icon.

I tried all of the fixes on this site and a bunch of others short of reinstalling Windows. Nothing had any effect. I think a large percentage of people have this problem because of Google Drive File Stream. Google seems uninterested in solving this problem as it doesn't affect everyone. I have coworkers with the same Windows version as me and their icons are fine.

  • I wrote a more detailed explanation for this in another question. – Zenexer Jun 29 '18 at 3:43
  • WOW! I spent hours trying to fix my windows icons, and yes Google Drive File Stream was breaking everything. I uninstalled that, and brought all my icons back. – Andrew Cetinic Jul 9 '18 at 13:42
2

If you have Google Drive File Stream, uninstall it and reboot your machine, and then check again because that worked for me.

1

Maybe your icon cache corrupted:

Try and delete %AppData%\..\Local\IconCache.db then restart.

Also do the actual applications have that icon? (Like on the start menu, or when you search it, or even on the desktop)

0

You can try to install the same build and language of Windows 10 on top of current installation keeping files and apps.

This can be done with a repair install using 1709 ISO.

Usually it helps in major cases.

Just run this before going to sleep and at the morning it will be working.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.