I am trying print from my PC centos7. So, when i tried to add printer through print setting, I couldn't find the driver for Canon MF240 Series UFRII LT. Please assist.

I have captured screenshots.

Printing Troubleshooter log

print setting - localhost

print properties Canon MF240 Series on localhost

New printer - searching for drivers

  • Proprietary drivers are seldom included in any Linux distros. Get them from the manufacturer and install. If you have any doubt or are stuck in some step of the process please ask a proper question describing exactly that, here or at Unix & Linux. – user772515 Jan 7 at 6:44
  • @MichaelBay : Thanks for the prompt response. I have printer driver CD but it shows driver only for windows. I am stuck in getting driver for printer. Also, How to transfer this question to Unix & Linux ? – spandan pradhan Jan 7 at 7:08
  • 2
    The question is on topic, it may fit better at Unix & Linux but it's fine here as well. And I said "get them from the manufacturer" implying download them from the website. usa.canon.com/internet/portal/us/home/support/details/printers/… – user772515 Jan 7 at 7:24
  • @MichaelBay Thanks it worked. All i need was to do following things: – spandan pradhan Feb 2 at 4:07
  • 1
    1. install 64 bit drivers (RPM) 2. Select old PPD when asked for setting option 3. Print Test Page. – spandan pradhan Feb 2 at 6:33

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.