1

I have aGSuite enrolled Chromebook (Google Pixelbook) that I no longer want to use with GSuite. Want to now enable Developer Mode and use as a personal device.

So I deprovisioned the device in GSuite Admin to remove the enterprise management and intended to reinstall ChromeOS from a recovery USB flash drive. That worked - the device shows as deprovisioned and I was able to reinstall ChromeOS from the USB flash drive.

However, when I try to enable developer mode (hold down ESC-Refresh while booting, then Ctrl+D) I’m told “The device owner has disabled Developer Mode for this device.”

Searching around, I found the setting I wanted to change is “Skip Boot Mode Check for Verified Access” in GSuite Admin (Device Management > Chrome > Device Settings). When I do that, it still doesn’t allow developer mode on the device.

I would have thought the reinstall of ChromeOS would clear this but the setting apparently persists, even on a deprovisioned device.

What am I missing?

  • Good self-answered stuff! – JakeGould Jan 7 '18 at 22:44
3

The key is deprovisioning the device stopped pushing policies to the device - so when I made the change to “Skip Boot Mode Check for Verified Access” (which should have allowed me to enable developer mode), the device didn't get that policy change since it was deprovisioned.

Sure enough, drilling into the device information for the deprovisioned device shows the last time it synced policies was yesterday - before I made the change to allow developer mode.

The trick is to reenroll the device in the enterprise, which will then push down the policy changes, and then enable developer mode. Of course, the device is now a managed device, so I will also need to do the ChromeOS recovery again (powerwash on an GSuite managed device just removes user data).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.