3

I am looking for a way to set VLC so that by default it will enable a specific subtitle track (some people prefer to have these on by default just for ease of watching if there are multiple things going, also some people who need the "close captioning" services might favor such too).

There are some seemingly Relevant settings: Tools > Preferences (show all settings) > Input/Codecs (note that I have also dug through some of VLCs configuration files and not yet found something that works).

I have not yet been able to get the desired effect using these or any others. Does anyone know a way to get the program to automatically select a default matching track?

  • I always though it "just does"... going to have a look at some settings... – Tetsujin Jan 9 '18 at 8:42
3

I don't have an examples specifically for Ubuntu, but I'm guessing the prefs are going to be similar to how they are on Mac - Windows appears to have a simple on/off switch, Mac doesn't.

From VLC - Documentation:Subtitles

Subtitles are enabled by default in VLC media player. To disable them, go to the Video menu, and to Subtitles track. All available subtitles tracks will be listed. Select "Disable" to turn off the subtitles. Depending on the media, a description (language, for example) might be available for the track.

To disable subtitles by default, select "Preferences", then "Show All". Select "Input/Codecs". On the "Subtitle Track ID" selection window, change the value to "-1". (NOTE: Changing the value in the "Subtitle Track" menu will not disable the subtitle file.) In the case of multiple subtitle tracks, a value of "0" will enable subtitle track 1, a value of "1" will enable subtitle track 2, and so on.

However, this doesn't seem to work in practise.
Setting the 'Subtitle track ID' to anything other than -1 seems to disable it entirely.

After some testing, I discovered the 'Subtitle track' can be set to -1 to find the first available track, or >=0 to find a numbered track.
Setting 'Subtitle track' to -1 in combination with a specified language in the 'Subtitle language' field would find the correct language, whatever track number it is.

On Mac, switch to the full prefs - Show All at the bottom of the Basic Prefs panel.
This is the setting I used to get it to find English every time & play automatically.

enter image description here

As an aside - the default key to toggle or cycle round subtitle languages is V.

| improve this answer | |
  • I have pretty much the same settings dialog but currently have the track ID set to 1 and also typed "English" in as the subtitle language. I have noticed though that when I start a DVD or video file that I still have to right click and enable subtitles, selecting the track at that time. – techhie Jan 9 '18 at 9:09
  • hmm... Instructions say "Subtitle Track ID" but actually that seems to be wrong. Empirically, setting that to anything other than -1 disables subs. I've tried playing with the "Subtitle track" number & that definitely chooses between languages. -1 plays the first found language, it doesn't disable. Changing answer... – Tetsujin Jan 9 '18 at 9:26
  • It would be great if the documented features actually did work as stated, – techhie Jan 10 '18 at 12:31
  • Yeah - though after working through it all yesterday, I'm actually happy with how I now have it set, in the pic above. [though apparently I should use eng not English but it seems to work] I'm guessing the Sub track -1 is acting as a wildcard, handing off to English, though I've not a clue what the Sub track ID is supposed to actually be doing. – Tetsujin Jan 10 '18 at 12:38
  • Setting French does seem to cause it the subtitles to default to French but there still seems to be a problem. The system doesn't try using that location for closed captions and you are right back to square one. – techhie Jan 10 '18 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.