5

So, my PC is in an odd state right now. I'll try to outline the order of events that led me here:

  • I updated Windows 10 x64 to the Creators Update. This occurred without problems.
  • The next day (I'm not sure if it was the very next boot after installing updates -- I used Creators update the night before for hours though), the first boot screen says "New CPU Detected!" and prompted me to go into BIOS or to accept default BIOS settings.
    • I don't know if the Creators Update is responsible for this, or if it was just coincidental timing.
    • To be clear, I have not changed any hardware
  • I accept default settings and things boot normal. I do notice on subsequent boots that indeed default BIOS settings apply (e.g. the splash screen is enabled; something I had turned off).
  • Subsequent boots go okay for a while. I decide to go into BIOS and tweak things (turn off splash screen mainly)
    • However, I do see a brief message of No hard disk detected! before boot proceeds normally.
  • I also decide to change the boot order, as it had my CD-ROM drive as the first in the list, when my SSD should be top of the list (where Win10 installed).
  • Oops! Problems now. Sometimes it gets to the Windows splash screen and freezes (where I do a hard restart). Others, it gives me the message Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key
    • The "freezing splash screen" doesn't seem to happen anymore. Only the message now

Now it seems that the only way I can boot my PC is if, on startup, I hit F8 to open the "select boot device" menu, and select the SSD that contains Windows on it. Beyond that, the PC is working just fine. From what I can tell, the SSD, while old, functions normally, and the CMOS battery appears to be working (it never lost the system time, for instance), but I'm not sure:

  • What made the PC think a new CPU was installed
  • Why can't it boot straight into Windows without manual intervention
  • If the recent update to Win10 Creative (x64 Pro) matters at all, or if it was just a coincidence.

EDIT: As an update, this morning my PC wouldn't boot at all.

  • I opened it up, discovered a forgotten third hard drive and removed it (the original one that came with the PC. No wonder BIOS showed 3. I guess I never mapped it...), and tried only leaving the SSD plugged in (I double-checked the SATA/power were flush... it's just kind of sitting in a 3.5" bay because this tower doesn't have SSD slots. I have it taped down though with electical tape.)
  • When I boot with just the SSD, it works fine and I don't have to do anything special (open boot menu etc) to get the PC to boot. It even shows up in BIOS now!
  • When I hook the data drive back up, though, I can only boot by mashing the "open boot menu" key at the start, and selecting the SSD. And even then it only works about half the time (i.e. my original problem).
  • So I dunno exactly what's wrong. I thought the SSD was toast but that isn't the case, unless this is a symptom of it going bad? I'm a total hardware newbie but it almost feels like the two hard drives together draw too much power, but that makes no sense (Got a beefy PSU in here, over 1k watts... an HDD shouldn't be stressing it).

EDIT 2: Here are my hardware specs:

EDIT 3: PARTIAL FIX: Windows re-enabled "Fast Startup" when I upgraded, which I'm pretty sure is why I initially got "Windows starts to boot, then freezes". I had this issue before and disabling Fast Startup fixed it for me. So I turned that off. In the occasions where my PC does manage to get to the Windows splash screen, I believe this fixes it.

Also, my BIOS version is 0501 (H:02 B:07), dated 07/17/2009. So I will try to upgrade it as per the comment.

EDIT 4: I updated BIOS to the latest available version. Initial boot post-install was the same problem. But after initial configuration (in which the SSD still didn't appear in the boot menu, but under HDD configuration it did, in which I moved it to the top) it seems to be booting normally. Two full shut downs + boots and it went straight into Windows.

EDIT 5: On a hunch, I checked the Boot Priority in BIOS after I changed the HDD order. And 'lo and behold the SSD appears there now. I set it to first priority, and no change (i.e. still booting fine). About the only hiccup I have now is that on boot the screen prints:

Marvell 88SE61xx Adapter - BIOS Version 1.1.0.L72
Initializing.

Followed by

Marvell 88SE61xx Adapter - BIOS Version 1.1.0.L72

Adapter 1
Disk Information:
    No hard disk is detected!

Been seeing that throughout this whole process. I think I've read in the past that this is innocuous (and it doesn't seem to affect anything now), but it is something that didn't used to happen before all this started.

EDIT 6: Some Googling reveals that that's referring to the ESATA boot attempt. It correctly notes that there's no hard drive plugged in. Initially I was looking in BIOS for a Marvell IDE boot, and was skipping the ESATA one. I'll probably turn it off, which took care of the message.

13
  • Yes, the Windows update may have also updated BIOS/UEFI thus reseting it to the defaults. Is your Windows installed in UEFI or Legacy mode? – user772515 Jan 10 '18 at 13:15
  • @MichaelBay I couldn't tell you off the cuff. It's an upgrade from Windows 8 which was from 7 which was originally installed nearly a decade ago (custom built machine). Is there some way I could find that out for you? – Scott Jan 10 '18 at 15:59
  • A machine of that age is likely to be BIOS and even early UEFI machines had Windows 7 installed in Legacy/CSM ("BIOS") mode. Many recent UEFI PCs had it sort of forcefully updated along with the regular Windows updates due to security issues and perhaps older ones as well. Just open the BIOS settings, recheck and save. – user772515 Jan 11 '18 at 1:08
  • @MichaelBay "Just open the BIOS settings, recheck and save"... for what, exactly? Afraid I need more direction here. – Scott Jan 11 '18 at 3:17
  • When you have opened your computer, you might have moved something. One candidate is that the CMOS reset pins fell off, but recheck all connectors. Other possibilities are that the CMOS battery needs replacing, a CPU pin was bent, or the PSU is weak. Cleaning around the CPU and its socket and resetting the thermal paste might help. Another possibility is that the BIOS itself has a problem, so you might update it to the latest version (we could help but we need the computer & motherboard models). – harrymc Jan 13 '18 at 17:50
6
+100

It seems like your BIOS got damaged somehow, perhaps from a power surge, and the problem seems to express itself in the BIOS only.

The best way to "fix" the BIOS is by installing the latest version. For the ASUS M4A79XTD EVO motherboard, the latest BIOS is Version 2102 from 2010/07/30. Try to install it, even if it's already the installed version.

2
  • Indeed it did! A combination of that and re-disabling "Fast Startup" did the trick (and I blame Creators Update for re-enabling it). Not sure what caused BIOS to go screwy, as I'm sure the Creators Update doesn't touch that. And there was no associated power outage with this event to my knowledge. Still, glad to have it resolved. Enjoy the bounty. – Scott Jan 15 '18 at 1:09
  • Almost let the bounty expire! I thought selecting the answer itself gave the bounty... Guess not! But now it's yours for good. – Scott Jan 20 '18 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.