8

I installed Linux Mint on a physical SSD, and ran like that for several years.

Now, for work, I need to run Windows 10 Pro on my desktop. To do that, I used a separate physical SSD, but left the old Linux SSD connected to the SATA inside the PC.

I would like to boot to the Linux Mint OS, using Hyper-V. I have set the disk to 'offline' in Windows Local Disk Manager, and attached the Physical Disk to the Virtual Machine in Hyper-V.

Attached Virtual HDD in Hyper-V

No VHD's are attached to the VM. When I Start the VM, I Hyper-V says "Start Successful" and it's now "Running".

But, the only thing I see in the Console is a flashing cursor in the top-left corner. I can hit and get it to advance, but no input/output is apparent.

One other (possible) complication: The disk is partitioned in a bit of a funky way. I can't recall at the moment the purpose for each partition, but it's in 5 different partitions -- including a Linux \Boot, \Root, \Swap, and \Home.

enter image description here

Oh, and it's EFI.

Any ideas?

17
  • 1
    OK, not easy to transform an existing installation into a VM but it's possible. Please wait for answers, I have no experience with the virtualization you intend to use.
    – user772515
    Jan 10, 2018 at 14:58
  • 2
    Is the virtual disk controller of the same type as when it was running on the physical machine? Same question for virtual BIOS settings regarding EFI/Legacy and disk settings such as AHCI. If nothing works, you might consider converting the disk to VHD.
    – harrymc
    Jan 12, 2018 at 20:02
  • 2
    Hyper-V has by intention limited access to the BIOS to what is available via Settings, and this is different for Generation 1 or 2 VMs. Generation 2 don't really have BIOS but an emulated firmware with more control than Generation 1. Most of the settings can only be accessed from the host via PowerShell. See this article for details.
    – harrymc
    Jan 12, 2018 at 22:27
  • 2
    How much startup RAM does the VM have? What about disabling Secure Boot? Note: To make a grub problem visible, modify /boot/grub/grub.conf, /etc/default/grub or equivalent to have timeout=100000 instead of the default timeout=5. For panic to work, change also crashkernel=384M-:128M to crashkernel=384M-:256M. Install the packages listed under Notes from here. Try also to boot from ISO, but note only 64-bit ISOs support UEFI. Gen1 might be safer but disk must be IDE.
    – harrymc
    Jan 15, 2018 at 8:12
  • 1
    I would suggest writing an answer to describe the solution, so others could benefit from your experience.
    – harrymc
    Jan 23, 2018 at 7:30

4 Answers 4

1

I agree with Jon Wadsworth. first I followed his method and failed 😂. The problem is that I can not ust superGrub.iso to boot the physical disk as it can not find the devices attched to hyper-v virtual machine.

Involuntarily I found that I can use a windows installation disk(like cn_windows_10_business_edition_version_1803_updated_sep_2018_x64_dvd_07b164ed.iso) to find and boot the disk.

1 yuo should detach the physical disk from windows disk management.

2 you should ONLy attach the windows installation disk image (.iso) to the hyper-v machine. then start it(if you have both iso file and physical disk attached, there will be an err). err of attaching two disk start vm and you will find "Press any key to boot from CD or DVD." press any key FAST.

3 attach the physical disk.

4 go back to the virtual machine, now you will see the windows installation screen,press"next","repair the your computer",then you will find the boot menu including your boot options of your windows system in the physical disk attached to the virtual machine.

most time ,you should follow the steps above every time you start the virtual machne. while only one time I upgrade the system from 1809 to 1903, it reboot successfully with no err. and after that , it failed giving the err in step 2. So the 4 steps are the stable ways to boot a system.

1

Just wanted to point out that without any external ISOs, Windows build 2004 will boot for me when attached to a hyper-V session on a host Windows build 2004 system.

  1. disk manager -> detach (puts my secondary (non boot) volume nvme ssd offline, the one I plan to try to boot in hyperv)

  2. create vm. skip the disk creation.

  3. open vm settings. select physical disk instead of vhd.

  4. WAIT for 90 seconds ore more on first boot for it to give up on the PXE boot.

  5. Let it boot. Log in. Something happens, and it restarts immediately after login.

  6. After second boot up, and second login, system appears stable.

No other actions necessary. Easiest P2V (physical to virtual) spin up ever.

2
  • I feel like this should work. Unfortunately, I can't find the option to detach the disk. The option just isn't there in disk manager. Tried inactivating but that wasn't the same thing. Dec 23, 2020 at 22:07
  • Alright, I managed to put my disk offline using diskpart (in an Administrative shell, not sure if that matters). First select disk=1 (you number might be different, see list disk), then offline disk. Quite easy, still not sure why I couldn't do it in the GUI. Dec 24, 2020 at 21:30
0

I was able to boot without the use of a VHD.

The key for me was to use the SuperGrub boot .iso --- Specifically, this version of it

I attached the SuperGrubDisk iso as a DVD drive, and booted to that. From there, I am able to select my boot volume on the physical disk, and it boots. SUCCESS!

Thanks @harrymc for all of your help with this!

For posterity, I am using a Gen2 VM on Hyper-V on Win10 Pro.

PS: Admittedly, this is not 100% ONLY using the Physical disk; it does involve the .iso to do the initial part of the boot. I believe that it would be possible do this without the .iso (perhaps re-writing the boot volume on the Physical Disk? But I'm happy as it is now, and can't spend any more time on this :)

1
  • In order to pass-thru a disk, it needs to be turned of "offline", which is unfortunate if you're trying to hyper-v boot a dual-boot os from a single disk.
    – kfsone
    Oct 7, 2018 at 20:50
0
  • I had an X.img file.
  • I converted it to vhd format with vboxmanage convertfromraw command.
  • I created Hyper-V VM - Gen 1 - I think this is the key point.
  • I atteched X.vhd and it runs as expected.

Before this method I got "in the Console is a flashing cursor in the top-left corner." too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.