8

I have just upgraded Thunderbird to 52.1.0 (32 bit) from a much smaller number. I used to be able to compose all messages and replies in my default font of Calibri. Now I'm getting Times sometimes. I read an explanation which says:

When you reply to a message, it is normal to use the same encoding as the incoming message. So if you haven't actively set other encodings, you'll get the defaults, which may well be tiny Times Roman.

The source doesn't say what to do about the problem.

What can I do with my settings to consistently send all my email in the same font (preferably Calibri)?

migrated from webapps.stackexchange.com Jan 12 '18 at 13:01

This question came from our site for power users of web applications.

3

I don't know if this is a bug or what, but what made things stick finally, for all email message responses, was to UN-check "Use Paragraph format instead of Body Text by default":

Composition Options

2
+25

Thunderbird cannot set absolute font and sizes. Your dictates for font and size are only meaningful for you, since the message will be displayed for the recipient according to his media and his own preferences. The message text will this way be scaled up or down as appropriate to suit the display device, and fonts will be substituted as required.

Meaningful changes you may do and expect them to carry over to the recipient are specifying larger and smaller typefaces to help with emphasis. You may also use the decorations offered by the toolbars and menus, but do bear in mind that your correspondent can elect to ignore these settings. It is not safe to rely on text decorations to make your point.

The way that formatting is added to an email message is by use of HTML tags. Here's a sample of the type of HTML code that might be used to request Helvetica font:

<span style="font-family: Helvetica,Arial,sans-serif;">Please see my notes below on setting fonts for multiple character sets.</span>

This means that "Helvetica" is the default sans-serif font. If you don't have it, then Arial will be used. If you don't have this either, then whatever is your system's default sans-serif font will be used.

The default font used when you compose HTML emails is set here:

Tools | Options | Composition | General → HTML

The fonts used to display messages on your screen are set here:

Tools | Options | Display | Formatting

If you don't want to have to accept other people's choice of fonts, press the Advanced... button and clear the check-box "Allow messages to use other fonts".

Note that these two settings don't necessarily have to agree. You may well compose in Times Roman and yet view your messages in Arial.

  • 1
    Thanks for your contribution. That didn't solve the problem but at least it encouraged me to look at the options for the umpteenth time and experiment some more, and so led to a solution. – aparente001 Jan 21 '18 at 16:31
0

I suggest you to use basic, cross-platform fonts such as Arial, Verdana, Georgia, and Times New Roman. In this way your emails will look the same on every clients.

Here you can find Best Practices

  • 1
    Okay, I switched my default font from Calibri to Arial, thanks for the recommendation. Unfortunately I'm still having the same problem. – aparente001 Jan 12 '18 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.