5

When I try to start my guest system, my Xubuntu 16.04 host gets totally freezed and I can't type or move the mouse or do anything. Also the guest system does not start. I recovered an old working snapshot, but that also failed when 97% were loaded. I have to do a hard reset then.

How can I log error messages in that case and how can i figure out why that happens suddenly?

7

Are you also on the Kernel Version 4.13.0-26-generic ? Apparently there is a problem with that Version and VirtualBox. You could try to install a older Version, but please be aware that it will not contain the most recent Security patches, i.E. for Meltdown.

https://askubuntu.com/a/995308/684252

2
  • Thanks for pointing me there, yes that seems to be le problém. Looks like I need to try out KVM now – Jeno Jan 12 '18 at 21:10
  • FYI. This still seems broken as of 4.13.0-38-generic – BillMan Apr 11 '18 at 19:31
2

I was able to replicate this problem. I found the work around here:

https://askubuntu.com/questions/994621/virtualbox-5-0-40-crashes-the-whole-host-since-update-to-kernel-4-13-0-26-generi

I test both solutions discussed, i.e. using an older kernel (4.10.0-28-generic) with VirtualBox 5.0.40 or upgrading to VirtualBox 5.2.6 with the 4.13.0-26-generic kernel. Either solution worked.

1

I don't have enough reputation to comment, so i have to type here in answers :(

I would start by using Grep to search /var/log/kern.log and /var/log/messages. You can search for the time when the system froze, and see what logs where generated before that. If your certain it was virtual box, you can search for that and see if you can dig any more information on it. There are also log files that are generated within Virtual box that contains information regarding BOTH the host and the vm. That might be a good place to look also if you believe it was the issue.

Check out https://blogs.oracle.com/scoter/virtualbox-log-files-v2 for how to find those logs.

Never-the-less, i would recommend KVM instead of V-Box. Oracle is not updating it as often, and the performance gains of KVM is starting to take a pretty far leap ahead in performance where it no longer makes sense to use V-Box, other than the awesome GUI. Not to mention they currently have some killer security holes known right now, and oracle has yet to update them after some time. Debian even dropped V-box temporarily from its repo because of the lack of responsibility of oracle updating the code.

1

You can install new version of VirtualBox from its website.
For simplicity, you can follow the accepted answer of this question.
I advise you to install version 5.1 because version 5.2 use Qt 5.6, so it look ugly in Ubuntu 16.04.

1
  • yeah! Installing 5.2 causes other errors but installing 5.1 fixes this issue: sudo apt-get install virtualbox-5.1 – ben.IT Mar 13 '18 at 9:20
0

This seems to be Bug #1736116 "[SRU] Host with kernel 4.13 freezes when starting a VM with VirtualBox"

There is now a fix in the virtualbox packages version 5.1.34, available in the in the xenial-proposed repository, and hopefully soon in the main repository.

For a quick copy/paste solution, this worked for me:

echo "deb http://archive.ubuntu.com/ubuntu/ xenial-proposed restricted main multiverse universe" \
| sudo tee -a /etc/apt/sources.list.d/ubuntu-proposed.list

echo "Package: *"                     | sudo tee -a /etc/apt/preferences.d/proposed-updates
echo "Pin: release a=xenial-proposed" | sudo tee -a /etc/apt/preferences.d/proposed-updates
echo "Pin-Priority: 400"              | sudo tee -a /etc/apt/preferences.d/proposed-updates

sudo apt update

sudo apt-get -t xenial-proposed install virtualbox virtualbox-dkms virtualbox-guest-additions-iso

Once the packages are moved from xenial-proposed to the main repository, you can

sudo rm /etc/apt/sources.list.d/ubuntu-proposed.list /etc/apt/preferences.d/proposed-updates

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.