0

I have Windows 10 Pro v.1709. I have two local accounts: mine and the one of my wife. Starting from the latest Windows 10 update, not every time but let's say 70% of times, when I log in with my local account, I discover that my wife account logged in too - of course that was not caused by my wife! I know that because if I click on my account image on Start, my wife's account is tagged with "Accesso effettuato" ("Access done", I guess in English).

The same of course happens when my wife logs in and then, instead of disconnecting, she simply clicks on my account to end her session, and then I log in.

enter image description here

Instead, this happens automatically, as there was a process that wakes up and logs in.

What can be done to fix this unwanted behaviour?

-1

Might be a long shot, but have you tried disabling automatic login?


Disabling automatic login:

First open the run window with the windows key and the R key (WIN+R), then go ahead and type: regedit and hit ENTER.

You should now be greeted with a small menu on the left, and a large empty block on the right (a UAC prompt may of appeared - and if it didn't open, check if the UAC prompt is in the taskbar).

Now head into (navigate using the left bar):

HKEY_LOCAL_MACHINE > Software > Microsoft > Windows > CurrentVersion > Authentication > LogonUI > UserSwitch HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\UserSwitch

On the right-hand side (the large box), double click the value Enabled, and go ahead and change it to 1.

Now so it doesn't automatically set itself back to 0, you want to right click UserSwitch on the left bar, head to permissions then click advanced.

Now click the button at the bottom of the new window that says Disable Inheritance.

Now at the top where it says Owner: SYSTEM click Change and type Administrators, then OK. If Administrators doesn't say ALLOW and FULL CONTROL leave a comment.

Double click/Edit on SYSTEM and set it to DENY, then click Show Advanced and Clear All. Then click the tick box for Set Value.

Hope I helped, and have a great day!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.