My “always on” home desktop today appeared to be totally unresponsive. It was clear that I had only one choice to power reset it. At first it seemed that it booted into my login screen, but again my I did power reset by mistake. From this point on I wasn’t able to boot. It shows “inaccessible boot device” blue screen.

Recovery or restore doesn’t work. From cmd prompt I see my C:\ drive and all files seem to be ok, entire chkdsk shows that everything is ok with the drive.

bootrec /FixMbr works, however bootrec /fixboot gives me “access is denied.”

bootrec /scanos and bootrec /rebuildbcd both show “Total identified windows installations: 0”

I tried to run it all from the UEFI partition by enabling it from diskpart but I still get “access denied” for fixboot, no matter what I tried. There is one suggestion for the “access denied” error: to format the UEFI partition and then manually create EFI\Microsoft\Boot\ in there and retry bootrec /fixboot but I find it outlandish to even consider it.

Any suggestions? What could be wrong?

  • I had the similar msg when converting mbr to gpt in the end all I had to do was reformat (d: was my efi) format d: /fs:fat32 and rebuild the efi bcdboot c:\windows /s d: /f UEFI
    – becker
    Apr 22 at 1:17

5 Answers 5


I ran into the same issue, the suggestion from Darko_65 in Microsoft Answers forum is what worked for me:

"bootrec" command sometimes has problems finding proper boot device and windows installation to fix.

Use "bcdboot" command to fix boot (bcdboot requires that partitions are specified explicitly!)

bcdboot C:\windows /s S:

specifies C: as Windows partition, S: as system partition.

Use "diskpart" or "mountvol" commands to map system partition.
  • 9
    Thank you. You saved m̶y̶ ̶l̶i̶f̶e̶ my cloned win10 installation on a new SSD drive.
    – Toc
    May 18, 2018 at 23:35
  • 10
    Saved my bacon too. Had cloned my SSD to a new bigger one then wiped. Just 'bcdboot C:\windows' fixed it for me.
    – AceJordin
    Dec 14, 2018 at 18:32
  • 3
    Bacons are still being saved for those of us who clone to larger SSDs.
    – Fls'Zen
    Mar 6, 2019 at 16:00
  • 4
    Worked for me. Simply running bcdboot C:\windows without the /s part sufficed.
    – xji
    Oct 9, 2019 at 9:29
  • 1
    Worked for Windows 7 x64 in UEFI mode too. If you don't see letter/volume on GPT disk, run diskpart, then select partition X and and set id=EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
    – radioxoma
    Dec 3, 2019 at 16:16

In the answer given by @aoetalks, copying the BCD files to new mount point didnt worked for me. It always ended up saying source files not found. It could be because my /EFI directory got corrupted.

Anyways, trying to boot with a Windows 8.1 USB media worked. All the commands, bootrec /fixmbr, /fixboot, /scanos, and /rebuildbcd worked fine and I'm back to my desktop in a few minutes.

It looks like the Windows 10 bootrec has some issues.

  • 4
    This should be the accepted answer. Worked for me too.
    – xyzman
    Jul 3, 2020 at 6:50
  • 2
    Wow, thank you! This is what finally worked for me! I think it has something to do with Windows 10 repair tools assuming a UEFI setup. However my partition uses the legacy MBR BIOS. I used Rufus to create a bootable USB from the Windows 8.1 ISO (and set the partition scheme accordingly).
    – Jet Blue
    Aug 11, 2020 at 8:36
  • 2
    August 2020 - confirmed this worked for me too. /fixboot failed persistently ("Access denied") on win 10 2004 install media. Worked first time using Win 8.1 install media.
    – Stilez
    Aug 15, 2020 at 6:30

It's been much easier for me: after 2 weeks (!!) of Windows 10 not booting with UEFI not recognizing my GPT disk anymore, I simply used diskpart from an installation DVD/USB:

list disk
sel disk 0
sel vol 1
attributes volume clear readonly
sel vol 2
attributes partition clear readonly 
sel vol 3

...worked for me so I could boot into Windows 10 after 2 weeks, WITHOUT reinstalling.

  • 2
    I've edited this answer to make the commands valid, as attributes partition... is not valid syntax and attributes volume... is the command that's likely being referred to instead, but I haven't confirmed that the answer works. Apr 16, 2019 at 6:22
  • 2
    After selecting the EFI volume, and confirming it is active (starred), entering ATTRIBUTES PARTITION CLEAR READONLY gives 'Virtual Disk Service error: The object is not found.'
    – ndemarco
    Apr 20, 2021 at 1:58

After installing Windows 10 cumulative update 2021-06 for 20H2 (KB5003637) my laptop didn't boot but displayed "Operating system not found" error message. I tried @aoetalks's solution but got Failure when attempting to copy boot files. error message.

Apparently my EFI partition got somehow corrupted, since I was able to fix the issue by completely recreating the EFI System Partition with following steps:

  1. Boot from Windows 10 USB
  2. Select your region and then click Next > Repair Computer > Troubleshoot... > Advanced > Command Prompt
  3. Enter recovery key(s) if you have BitLocker enabled
  4. At the command prompt enter following commands (instructions found from NavyLCDR's post):
lis vol  <- note which drive letter your Windows partition is assigned
lis dis <- note the disk number of the drive containing your EFI system partition
sel dis # <- replace # with the drive identified above
lis par <- note which partition is the EFI System partition
sel par # <- replace # with the partition number identified above
del par override
cre par EFI
for fs=FAT32 quick
assign letter=s
bcdboot C:\Windows /s S: /f UEFI <- note may need to change C: to the drive letter identified above
  • Thank you for the detailed instructions! After a BIOS update my wife's Windows 10 laptop refused to boot with a BCD error code 0xc0000098 and I was able to use this to fix it.
    – smsearcy
    Jan 12 at 19:42
  • del par override gives "Virtual Disk Service error: Delete is not allowed on the current boot, system, pagefile, crashdump or hibernation volume."
    – BadHorsie
    May 14 at 12:03

if you're here with "inaccessible boot device" and nothing else in this thread has helped you, then you're probably trying to boot from an enclosure or usb/nvme drive - you need to do this:

edit the registry HKLM/SYSTEM/HardwareConfig/{..guid..} and set BootDriverFlags = 0x14 (the guid is system specific and you could have multiples if you've booted different systems with the drive, if you're unsure which one you can just edit them all)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .