0

about to deploy many unattended machines into production, we do not wish to have windows updates applied automatically under any circumstances. We have a separate management process for application of critical hotfixes.

Despite having disabled windows updates multiple ways, we still experience on occasion "Getting Windows Ready" or "Don't turn your machine off" messages following a shut down or reboot. The machines then require a hard reboot.

Updates are disabled via methods:

  1. Registry Update - DisableOSUpgrade & NoAutoUpdate
  2. Changing all Network modes to 'metered'

Event viewer (WindowsUpdateClient) shows that "Windows Update successfully found 107 updates" today. So Windows is clearly looking and still thinks it should be doing something with these updates.

What further steps can I take to stop the windows update process and prevent these shut down messages?

4
  • What does your Windows Update History indicate?
    – Ramhound
    Jan 14, 2018 at 17:07
  • You don’t indicate what version of Windows you are running. Question is currently too broad to answer
    – Ramhound
    Jan 14, 2018 at 18:05
  • @Ramhound windows 10 LTSB
    – Damo
    Jan 14, 2018 at 18:52
  • Why are you leaving a comment instead of editing your question?
    – Ramhound
    Jan 14, 2018 at 18:54

1 Answer 1

0

Try this policy:

Administrative Templates\Windows Components\Windows Update\Configure Automatic Updates

It will stop automatic updates but will not hide update options for users.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .