0

I have faced this issue for a few weeks now and it has disabled my multi-monitor setup and greatly decreased my productivity. I seek a workaround or resolution from someone who's already dealt with it. The trouble is happening on my Acer Aspire AX3400G-U4802 desktop PC. I've posted the issue at the Acer website, NVIDIA, and Microsoft.

So far, not one of these companies has given me an adequate answer though I hear the problem has affected many PC users that depend on NVIDIA graphics. I'd appreciate hearing from anyone that has gotten any further than I have!

My Windows 10 Pro installation was automatically upgraded to Windows 10 Pro version 1709 recently and it's since then that my NVIDIA GeForce 9200 on-board graphics card fails with the message

Windows has stopped this device because it has reported problems. (Code 43)

I have tried various versions of the NVIDIA driver, even using 3DGuru's DDU (Display Driver Uninstaller) to completely remove the new driver and start over but it's been no use.

I do have a dual-boot setup, so going back to Windows 7 does show me that all my hardware is fine. Also, prior to this upgrade to Windows 10 version 1709, whatever version of Windows 10 I had earlier was running just fine.

I've even restored my old Windows 10 version using the built-in Windows 10 Restore procedure and everything worked again. I noticed that the working NVIDIA driver was v341.81 at this point.

Eventually, however, Win10 still goes back and upgrades that driver up to v342.01 against my wishes and destroys my multi-monitor setup again. While that error code 43 appears in Device Manager, my Windows 10 environment won't detect my second monitor and displays graphics very slowly.

Attempting to force Windows not to install further driver updates doesn't seem to help; it still goes out and updates my video card driver.

Does anyone know of a sure-fire correction to this issue?

8
  • Have you seen any of the solutions here: superuser.com/questions/1156317/…
    – Mokubai
    Jan 15, 2018 at 22:09
  • Which leads you to this question: superuser.com/questions/964475/… once you have a "good" driver you can block Windows from updating it.
    – Mokubai
    Jan 15, 2018 at 22:10
  • Your latter method to block driver updates on a specific driver is new to me; the method I tried used the Group Policy Editor per intowindows.com/how-to-disable-windows-update-in-windows-10) as well but didn't seem to effectively curb the updates. I will try your way per that last link you posted and report back. Jan 15, 2018 at 22:21
  • Alright here I am after following the steps but I'm finding myself in the same predicament--however, I've also determined something else has changed: although my NVIDIA GeForce 9200 version is back to 341.81, Windows 10 is currently at version 10.0.16299 Build 16299. When that NVIDIA driver version was last found working on my machine, the Windows version I had was also 10.0.10240 Build 10240. Jan 16, 2018 at 1:00
  • Therefore, it seems I have not just a driver issue but also some sort of incompatibility with even this pre-FCU (Fall Creator's Update) version of Windows! I'll have to do a complete Windows Recovery again if I hope to get any closer to my working environment, and hopefully then I'll also be able to run this Microsoft utility mentioned in your link (wushowhide.diagcab) in time to stop the automatic update of the driver, as well as perform the other steps in the other Group Policy Editor link I mentioned above to hopefully ALSO stop Windows 10 from upgrading at all. What do you think? Jan 16, 2018 at 1:00

1 Answer 1

0

The problem has cleared up now. If you read my latest UPDATE on the comments to the original question, I got a hunch that my additional video screens driven off j5create JUA370 USB to VGA adapters were somehow conflicting with the NVIDIA driver. What I did then was download the latest driver (j5create-USB_Multi_Adapter-18.01.0118.3192.exe) for the JUA370 unit at https://en.j5create.com/collections/display-adapters/products/jua370?variant=10609924868. I executed the setup file I had downloaded there, rebooted, and that was it! So it seems that either the FCU installation disabled the original driver, or it removed the driver completely, or the J5 guys released a new version of the driver that wasn't automatically updated when the FCU update took place on my PC and I was left with having to manually investigate what the issue was and install the latest driver myself.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .