1

My keyboard on my laptop got stuck in a sort of a weird mode, where keys and key combinations don't do what they are supposed to do. I do not know how I got into this mode, maybe I pressed some weird combination that got me in this mess, I don't know.

The keyboard is an AZERTY keyboard, the laptop is a Dell Inspiron 17, 7000 series, model 7737, running Windows 8.1.

To illustrate, the following things happen (or don't happen) when pressing keys:

  • The left SHIFT key makes it so that the "Devices" pops out at the right side of the screen (not the right SHIFT key, that one just doesn't do what it's supposed to do)
  • a and z type normally, but the e key types nothing
  • r and t type normally, but the y key acts like arrow-up (weirdly, it printed out 8 earlier today)
  • u and i type normally, but o types nothing; p types normally
  • I'm skipping a few weird ones, on to x which turns toggles "Airplane" mode on/off; the c key does that same thing
  • Next, none of the WIN-KEY combinations work, for instance WIN-KEY+l no longer locks, WIN-KEY+e no longer opens Explorer, WIN-KEY+m no longer minimizes all applications, etc. The WIN-KEY itself no longer shows the full screen "Windows overview" (or whatever that's called).
  • The arrow keys work, except for right-arrow, that simply does nothing.
  • Pressing CTRL+SHIFT+left-arrow no longer selects text up until the previous word boundary, it just moves to the previous word boundary

I've checked sticky keys, toggle keys, filter keys, they're all not activated.

I've had this problem once before, and I recall I pressed some combination of keys that got me out of this mess. I might have done this randomly, because I don't recall what I did to get me out this mess.

Does anyone recognize this weird mode, and if so, how does one get out of this particular mess?

5
  • not a solution but rather a cause of why similar weird symptoms occurred in my case, which although not the same, the root cause could be similar. I cleaned my laptop with vanish and somehow it filtered in the keyboard, next day some keys worked, others did strange stuff.
    – DRP
    Jan 15, 2018 at 15:05
  • @DRP Haven't done that in about two weeks, and I used cleaning fluid that is intended to clean keyboards. Still, thanks for your input!
    – TT.
    Jan 15, 2018 at 15:07
  • @TT. Dude have you tried going to the language tool bar near the task bar? Just right click on the startbar, go to tool bars and enable language. Then click on the "EN"(probably, dunno what language you speak) and change it whatever you want. Algo you can go Control panel -> "Regional Config and language"(I think that's the translation) -> Keyboard and language -> Change Keyboard
    – dmb
    Jan 15, 2018 at 15:09
  • @dmb I'm no beginner :-), those are the first thing I checked. I've tried all typical venues like keyboard settings, language settings and so on. Everything is as it was before. Only one language installed (English (UK)), just one standard keyboard present (PS/2). driver up to date etc, stats="device working properly"; Region = Match Windows Display language, locale=English UK. Thank you for your input!
    – TT.
    Jan 15, 2018 at 15:30
  • I'm starting to think there's a decent chance my keyboard is broken. No matter what combination of keys I try to get "unstuck" it just isn't working... I'm going to try maybe attach a USB keyboard in following days, see what the effect is.
    – TT.
    Jan 15, 2018 at 16:16

2 Answers 2

0

So after about four hours of searching and trying everything out, I called the office to get a replacement portable. Turned off the portable, two hour drive there and back, turned it back on and the "weirdness" is gone now....................................... (number dots equal my frustration level at the time).

In any case, the portable is just over three years old, so I kind of guessed after a while that it's showing signs of aging. Le sigh.

0

I found I had exactly this issue down to the weird keymapping on a personal Dell Inspiron 7737. Hard power off and battery removal, two hours plus downtime, reassemble/restart, and it started working fine.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .