0

After updating to the Dell XPS 9560 Bios dated January 8th 2018, fingerprint reader and pin entry no longer work.

When trying to set the Fingerprint Windows Hello, I get the code 0x80070032.

When trying to set a PIN I get the message service unavailable or We couldn’t sign you in. The request is not supported.

1

The general instructions for resetting PIN entry needed to be run. This include taking ownership of the NGC folder, and removing its contents and resetting the default permission as documented in Solution 1 on this page. http://windowsreport.com/pin-windows-10/

In case that page is unavailable, take ownership of the folder C:\Windows\ServiceProfiles\LocalService\AppData\Local\Microsoft\NGC (instruction to be found elsewhere), remove the contents of the folder and reset the permissions on the NGC folder by opening a command shell using WindowsKey + X and selecting Windows Powershell(admin) then entering: icacls C:\Windows\ServiceProfiles\LocalService\AppData\Local\Microsoft\Ngc /T /Q /C /RESET

At this point, PIN setup should function but not the Fingerprint reader.

Backlevel the bios by shutting down the machine. Remove the power cord. Hold Ctrl+ESC and then put the power cord back in. Downgrade the bios version from the menu that appears.

Reboot, hitting F2 while booting to go to the bios menu. In the security section of the bios menu, you should now see TPM 2.0. In that section, uncheck the TPM checkbox and apply changes.
Check the TPM box AND the clear BOX, apply changes, exit and boot.

Download and install the TPM 2.0 Firmware from Dell. This did not appear in my driver list anywhere at the time of writing this and it was not applied via Dell Update. http://www.dell.com/support/home/us/en/19/Drivers/DriversDetails?driverId=RF87D&fileId=3670117989&osCode=WT64A&productCode=xps-15-9560-laptop&languageCode=en&categoryId=SY

An unfiltered list of drivers for the XPS 9560 can be found here as well http://www.dell.com/support/home/us/en/19/product-support/product/xps-15-9560-laptop/drivers

Run the admin command shell again and run the command tpm.msc. If you get a message TPM is owned follow these Dell instructions. http://www.dell.com/support/article/us/en/19/sln302620/tpm-unable-to-change-between-12-or-20-because-tpm-is-owned?lang=en

After clearing and rebooting TPM according to those Dell instructions, I also had to go back into TPM.msc and run the menu on the right that said Prepare TPM (note this article seems to show it as "Initialize TPM".

Once everything is good, the center of the TPM.msc screen status section should say "TPM ready for use"

From there you can now go back into Windows Hello configuration and set up Fingerprint security.

(I'm not a frequent Superuser poster so apologies if the formatting or detail is not up to snuff. I mostly expect Dell to create a support note of higher quality than this but posting here to help anyone in the mean time, since this took quite a while to resolve.)

  • This worked for me. Thanks, @richard-collette! – Andy Hopper Feb 3 '18 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.