Windows Media Player 12 (Windows 7) has added some very wrong album art files on some of my files. How can I remove the album art without having to replace them?


Use MP3tag (freeware) to remove the album art.

Instructions (thanks @BornToCode):

  1. Select relevant files from MP3tag explorer.
  2. Move the mouse cursor to the bottom of the left pane.
  3. Right-click on the cover image.
  4. Choose Remove cover from menu.
  5. Click ctrl-s to save.
  • 4
    Care to expand on this answer? Like some instruction, links, etc.? – Ƭᴇcʜιᴇ007 Jun 24 '12 at 19:40
  • Images might work well. This would also depend on whether WMP12 embeds album art. – Journeyman Geek Jun 25 '12 at 0:44
  • 1
    @Ƭᴇcʜιᴇ007 - Instructions: select relevant files from MP3tag explorer, move the mouse cursor to the bottom of the left pane, right click on the cover image - choose "remove cover" from menu, then click ctrl-s to save. Here's the download link. – BornToCode Dec 30 '18 at 9:55

In version 11 (11.0.5721.5268) follow the following procedure from the library view:

Right click on the track and select "Advanced Track Editor".

Select the "Pictures" tab.

Select the image you want to remove and click on "Delete".

However, according to Wikipedia:

The Advanced Tag Editor (ID3 tag editor), which allowed users to edit metadata for media files file, is removed. Editing metadata in Windows Media Player library and in Details pane of Windows Explorer is still supported. Source

  • Hm... I can't seem to find any such option. – Svish Apr 7 '10 at 21:08
  • @Svish - what options do you see when you right click over the track title? – ChrisF Apr 8 '10 at 11:38
  • If you use Windows Explorer to browse to the music file and right-click the file, select properties, you should have a Details tab where you can change the metadata except for the album art. – Jason R. Coombs Apr 8 '10 at 12:06
  • 1
    @Jason, If only it was the other details I wanted to change :p – Svish Apr 14 '10 at 18:19
  • Play All, Play, Play next, Add to..., Edit, Rate, Find album info, Delete, Properties, Open File Location – Svish Apr 14 '10 at 18:21

Open your song/album in iTunes, right click on the song and select Get info. In last tab Artwork, select photo and press Delete. Then use Windows Media Player.


I ran into this problem this weekend and was really disappointed to find I couldn't delete the album art. Most of the resources on the web talk about how to hide the album art, and not how to delete it.

Ultimately, I was able to delete it by showing hidden files and folders and deleting all of the metadata files.

The challenge is if Windows 7 is adding the wrong album art, it will probably automatically replace it with the wrong art again (unless it was a selection you inadvertently made).


I recently had this problem too and even with all the tools and tutorials, I couldn't get Album Art from Windows Media Player 12 to stop coming back. I eventually figured it out by myself and I would like to contribute a compilation of all the tutorials that I tried for Windows users running WMP 12.0.

If you would like to remove cover / album art from your mp3's whether it be embedded into the mp3 or not then follow the first 3 methods. If all else fails then try the 4th method. Here they are:

METHOD #1: Get the freeware tool Mp3tag.exe from http://www.mp3tag.de/en/download.html Mp3tag is a great tool for clearing / renaming tags on massive ammounts of files. I used it to remove all tags from 654 files at once!

METHOD #2 (a little time consuming): Make Windows show you hidden files and folders and operating system files too. You will see a lot of .jpg files with the names AlbumArtSmall.jpg or something that looks like this: AlbumArt_{37A0C6A2-FE4A-40F4-8E27-42E526A89D51}_Large.jpg. Look through each one and find the ones that look like the album art you are seeing and delete them.

These two methods I found from here: http://www.winhelponline.com/blog/remove-mp3-album-art-embed-images/ They have a fuller tutorial than I could explain here.

METHOD #3: I read on another forum to go to the AppData folder where windows media player is and delete some files. They explained this: "Close Window Media Player. Press Windows Key+R to bring up the Run prompt and type this %localappdata%/microsoft/windows media/ and press enter. There you will see a folder with the version of your WMP. (In my case I see a folder called 12.0) Go in this folder and delete everything inside. Reopen Windows Media Player and the album art should be gone."

This method didn't work for me. Not sure if it really does anything but WMP is still working fine on my computer. If it helps in rare cases then good.

METHOD #4: This is what finally worked. After looking around in my folders I found one called "Media Player". Open a Run prompt (WinKey+R) and type this in: %localappdata%/microsoft/media player/ Now open another run prompt and type control folders and press enter. In the view tab select the bullet "Show hidden files, folders and drives" and uncheck the box "Hide protected operating system files (Recommended)". A warning will pop up. Just click yes. Now inside the Media Player folder you will see a folder called "Art Cache" click on it and inside is another folder called "LocalMLS" open that too. Here is where I found all the pesky album covers that never went away even after doing the above 3 methods and multiple computer restarts inbetween. Only thing to do now is EXTERMINATE! (delete the ones you don't want).

Hope this will help people in the future that are having the same problem as me.


I solved this issue by clicking on the little dropdown icon next to the "search" bar, then clicked on "Details" instead of "Expanded Title". I then chose my columns and placed ARTIST first and sorted them. I am now able to sort by artist and type on the keyboard to quickly navigate through my music.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.