2

I spilled water on my MSI CX61's keyboard over a year ago and didn't do the right thing, i.e. turn off the laptop right away and dry it. As a result certain keys stopped working or started working improperly, but the rest worked fine.

Finally I bought and installed a new keyboard today (I used a USB keyboard in the meantime), it's a keyboard for MSI CR61, which seems to be totally identical and fits just fine (https://msi.com/news/detail/6D8DlklC6brwRZXFeAVLFvtoH479F0c-MlxaNvOrq7rEznSaKyelYa72MS8tQVywiidMKM1UuTiNcBpQOFw8Ag~~). Although, all the keys are completely messed up like there's a wrong mapping.

For example:

  • I press 'r' and get 'w'
  • I press 'w' and get 'b'
  • I press 'u' and get 'r'
  • I press 't' and get F1
  • I press backspace and get space

How can I fix this? Typed this with my USB keyboard which still works fine with all the keys doing what they are supposed to do. I'm on Ubuntu 17.10.

4
  • 1
    Is it a steelseries keyboard? if so, check the key mappings in the SteelSeries software. Otherwise, check the keyboard layout windowscentral.com/how-change-your-keyboard-layout-windows-10 – Blaine Jan 16 '18 at 5:33
  • 1
    If @Blaine suggestion is not working - I'd say you better off sticking to the USB (wired or wireless) Keyboard as there may be other hardware component failed / short circuited from the water damage that you done before (could be a rust somewhere etc). The reason why your USB keyboard works without issue because it input via the USB device, but your laptop keyboard uses whatever mainboard connectivity to the keyboard (most laptop uses ribbon cable) and if the ribbon cable receiver has some rust on it - that is pretty much it. – Darius Jan 16 '18 at 5:35
  • Nope, not a steelseries, just a regular keyboard. I'm on Ubuntu, not Windows. The still working keys of the old damaged keyboard were working properly, the new keyboard has all the keys on the wrong places. – Alexander Jan 16 '18 at 5:42
  • The new keyboards has 1 extra key on the bottom row, but is identical otherwise. Could it be an incompatibility problem? – Alexander Jan 16 '18 at 5:45
0

Well, I cleaned the connection slot with a bit of alcohol and re-connected the keyboard. Seems to be working fine now. Maybe I didn't connect it properly the first time.

2
  • 1
    kind of bizzar that a loose connectoin caused different keystrokes... nonetheless, glad it worked! – Blaine Jan 16 '18 at 6:34
  • yeah, I know. Maybe the ribbon cable was twisted or something. Thanks! – Alexander Jan 16 '18 at 6:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.