0

Is it possible to force Windows 10 to prompt for credentials when opening admin level functions when logged in with a standard account?

In Windows 7, when I open regedit from the run command, it automatically prompts for admin credentials. In Windows 10, it just opens and I can't make any changes because I'm using a standard user account. Same with Group Policy, only in Windows 10, it explicitly says I don't have permissions, rather than just prompting for credentials.

It's also the same with installing applications, however, this isn't as inconvenient because I can just right-click the installer and choose "Run as administrator". In Windows 7, I would just double-click any installer and it would prompt for credentials.

I support hundreds of computers and I frequently have to remote in and run admin level tools (compmgmt.msc, devmgmt.msc, eventvwr, etc.). I find it very convenient to press the Windows Key + R and type in what I want to open. Now, I have to right-click the Start Menu, choose PowerShell (as admin) and type it in there. Or I could press the Windows Key, type in the command, and press Ctrl+Shift+Enter to bring up the UAC prompt.

I know this is trivial and I could just change the way I do things, but I was just wondering why this has changed and if there's a way to change it back. I checked the User Account Control policies and they are set the same on our Windows 7 and 10 computers.

  • 1
    "In Windows 7, when I open regedit from the run command, it automatically prompts for admin credentials." - This is due to a group policy. If you are not getting a prompt it means your group policy configuration isn't the same. – Ramhound Jan 16 '18 at 17:09
  • Which Group Policy though. I confirmed that all ten of the User Account Control policies located in Computer Configuration-->Windows Settings-->Security Settings-->Local Policies-->Security Options are the same on our Windows 7 and 10 computers. I don't know what other policies would affect this function. It's the same on my home computer, so I think this is a default Windows 10 setting. I'm surprised nobody else has mentioned this online. At least I couldn't find anything. – ShawnJJB Jan 16 '18 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.