0

I have just installed GIMPPortable 2.8.22 (32-bit) on a Windows 7 Pro (64-bit) machine.

I cannot open or save JPEG files. It seems there is something wrong GIMP trying to load the file-jpeg.exe file, but I see no specific errors. All I get is unknown file type when trying to open a jpeg directly. And if attempting to export an xcf image, JPEG is not listed as an option. I can use PNG and other file types fine.

When I look at the plug-ins folder in Edit > Preferences, these two folder are listed:

I:\apps\GIMPPortable-2.8.22\Data\.gimp\plug-ins
I:\apps\GIMPPortable-2.8.22\App\gimp\lib\gimp\2.0\plug-ins

The first folder does not exist. The file-jpeg.exe file can be found in the 2nd folder (the installer put it there), along with all the other standard plugin files.

On a whim, I created the first folder and copied file-jpeg.exe there...and GIMP then worked w/JPEG images as expected! Thinking to make file management easier, I then moved ALL the plugins to that folder..but then GIMP would fail again, as before.

I have noticed that the "file-jpeg" is NOT listed in the pluginrc file upon initial install. The pluginrc file is located here:

I:\apps\GIMPPortable-2.8.22\Data\.gimp\pluginrc

Once I copied file-jpeg.exe to the 2nd folder and re-started GIMP, that entry was then found in the pluginrc file.

I have attempted to create and use the file GIMPPortable.ini, containing a modified PATH statement (a supposed fix to this issue), but that did not work.

So copying file-jpeg.exe to the first plug-ins folder has got it working...but it is very hacky, and I'm sure I'm missing out on other plugins TBD later. So my specific questions are:

Why is this specific problem happening?

In general, is there a way to view error messages in GIMP?

Thanks.

  • 1
    Gimp has an error console. This info is probably output to a log file somewhere, as well. You'll probably need to look at those errors in detail to answer your other question – jpaugh Jan 16 '18 at 19:25
  • @jpaugh, thanks for mentioning error console and providing the link. I checked it out. Unfortunately, it provided no more information than the graphical error dialog box that pops up. I tried having it write the errors to file, but that contained no additional output either. That made me think to look for a "verbosity" flag, though...details in solution. Thanks! – atreyu Jan 17 '18 at 15:23
1

Based on jpaugh's suggestion to use the error console, I found the --verbose command line parameter. This, coupled with --console-messages (both referenced here), I was able to get a better look at what was going on at GIMP start-up.

Googling the errors I found in the error console led me to this thread, which recommended putting my G'MIC plugin files/folders in its own folder, and adding that folder to the list of plug-in folders under Edit > Preferences.

I am still not sure exactly what is going on (the verbose console doesn't mention anything specific that I can see), but clearly there is a conflict with the G'MIC plug-in files and file-jpeg.exe...but I'll stop here, as this is a reasonable solution.

I can now use GIMPPortable with JPEG support, and use the G'MIC plugin. Hurray!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.