18

I'm running Firefox 3.6.3 on Windows 7. And I still got some pop ups in new Windows (particularly the problem always reoccurs at one website)

19

I found the correct solution via a similar (but slightly different) question:

* SU won't let me hyperlink to about:config?

4

I use the Tab Mix Plus extension for this. It has tons of options for tweaking tabs to work exactly how you want. I have it set to "single window" mode which makes everything open in a new tab, no matter what.

  • 2
    You don't even have to use Single Window Mode; you just need to set it so that all popups open in new tabs. That way you can still manually create a new window if you ever need to. – Sasha Chedygov Apr 8 '10 at 4:00
0

I have the same problem with some internet banking sites. I have a couple of workarounds which I use:

First, try bookmarking the popup. For ANZ bank for example, if you click "log on to internet banking" you get a popup of https://www.anz.com/INETBANK/bankmain.asp which is the logon form. You can bookmark this and always start here instead of at the main page.

Second, if that doesn't work, for example going straight to NAB's logon at https://ib.nab.com.au/nabib/index.jsp just gives you a blank page, you can start at the main page (nab.com.au), click the link to get the popup, then drag the resulting tab back to your main FF window. If you can't see the tab strip to get at the tab, you can make it appear by pressing Ctrl+T to open a new tab.

Finally you can resort to a different browser. IE 8 respects my "always open popups in a new tab" setting. Opera does too but the latest version (10.51) is a bit buggy - I'd wait for version 10.52.

  • @Hugh - Your rep is very 1337. =D – Nathan Taylor Apr 8 '10 at 2:03
  • @Nathan Taylor: - yeah I noticed that. I saved a screenshot in case it changes :) – Hugh Allen Apr 8 '10 at 2:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy