0

I'm trying to use lightdm service for my workstation but not being able to enable it. I have removed gdm.service using yum remove gdm and currently at init 5.

Now if I pass the command

systemctl enable lightgdm.service

I'm getting an error:

Failed to execute operation: File exists.

And if I run

systemctl status lightgdm.service

it shows:

lightdm.service - Light Display Manager  
Loaded: loaded (/usr/lib/systemd/system/lightdm.service; disabled; vendor preset: enabled)  
Active: inactive (dead)  
Docs: man:lightdm(1)

Upon reboot the system comes as black screen.

Current status of the system:

$ systemctl list-unit-files | grep gdm  
gdm.service masked  
$ systemctl list-unit-files | grep display  
display-manager.service masked  
$ systemctl list-unit-files | grep lightdm  
lightdm.service diabled

How to enable lightdm then?

1 Answer 1

0

You have to disable the GDM service before you enable the LightDM service. With Yum you just uninstalled the GDM package which is not the same as the associated SystemD service.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .