I'm running an Ubuntu 16.04 on my laptop, a normal process is to upgrade almost everyday, today when i enter "sudo apt list --upgradable" it showed me this message:

❯sudo apt list --upgradable
 Listing... Done
 debhelper/xenial,xenial 10.2.2ubuntu1~ubuntu16.04.1 all [upgradable from:9.20160115ubuntu3]
 N: There is 1 additional version. Please use the '-a' switch to see it

So i did as recommended, i enter:

❯sudo dh -a
 dh: No compatibility level specified in debian/compat
 dh: This package will soon FTBFS; time to fix it!
 dh: Compatibility levels before 4 are no longer supported (level 1 requested)

Then i ran:

sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Why it isn't upgrading dh?, What can i do to fix it?

Thank you in advance.

  • I had the same issue, used synaptic and managed to get this upgraded. Source of the issue may have been having a ppa (tista/adapta) that included a debhelper version identical to the latest from xenial-backports, I used this command to figure out which: apt-cache policy debhelper – kprist Jan 29 '18 at 10:09
  • The recommendation had nothing to do with running dh -a in the middle of nowhere! That command sure is part of debhelper, but debhelper is a program that has nothing to do with the apt upgrade process. dh is to be used when you're developping a debian package. You would use it inside the makefile that builds the .deb binary packages from a unpacked debian source package. The error message it prints here is really not helpful. What happens is that it's looking for a file debian/compat, but since you're not in a package source tree, that file isn't found. – Johan Boulé May 3 '19 at 22:13
  • The recommendation was to run apt list --upgradable -a – Johan Boulé May 3 '19 at 22:18

Sadly I cannot comment yet, I ran into the same problem. If you actually run:

sudo apt upgrade debhelper

it returns an error stating that

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 debhelper : Depends: dh-autoreconf (>= 12~) but 11 is to be installed
             Depends: dh-strip-nondeterminism (>= 0.028~) but 0.015-1 is to be installed
             Depends: dpkg-dev (>= 1.18.23ubuntu3) but 1.18.4ubuntu1.3 is to be installed
E: Broken packages

At least I I am running on KDE Neon LTS (based on 16.04) so I assume that error can only be fixed by the package managers.

| improve this answer | |
  • This does not provide an answer to the question. Once you have sufficient reputation you will be able to comment on any post; instead, provide answers that don't require clarification from the asker. - From Review – Dave M Jan 27 '18 at 11:28
  • Wow thanks a lot, I even mentioned that. I hoped it might help someone with more experience. I hate those toxic communities where you cannot do anything without getting angry comments. – matt3o Jan 27 '18 at 11:35
  • Also the question itself is no question for this forum but rather for Ubuntu. It would help the person a lot more to point that out but hey, let's rather refer to the guidelines which won't help anyone – matt3o Jan 27 '18 at 11:37
  • @matt3o I'm going to try to show you that this isn't about being "toxic" but rather it's about being on-point, focused, topical. SO sites are about getting down to business: find your answer and get out. The downvote is because your "answer" here isn't helpful for the poster's question. You're simply stating "I have this problem too," which doesn't help anyone get a solution. When someone new comes here to find an answer and reads your response, they're not helped at all. To mitigate this problem, SO sites rank responses. This way someone can easily filter out this not-useful response. – Malcolm Feb 14 '18 at 21:22
  • Yes I know that. But 1) other communities just convert those "wrong questions" into comments. As you surely see I cannot comment yet 2) how about a short "thanks for trying to help but that's not the way". I will delete this question anyways. Just saying this is a negative environment. Be a little nice and people will love to help out. – matt3o Feb 14 '18 at 21:25

After looking for intricate solutions almost everywhere, i decided to try something simpler and transparent : use aptitude

sudo aptitude update

it found some broken packages, then:

sudo aptitude upgrade

it asked me if i wanted to repair the broken packages, i enter "y" and it started to fix all the broken packages.

I hope this solution can help you too.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.