8

I installed VMworkstation on a fresh Windows 10 operating system. When I tried to create any machine I got the following error:

VMware Workstation and Hyper-V are not compatible. Remove the Hyper-V role from the system before running VMware Workstation.

I checked the "Windows Features" and I found that Hyper-V is disabled. Also I used the following CMD shell and power shell commands to disable Hyper-v.

CMD Shell

bcdedit /set hypervisorlaunchtype off

CMD Shell

dism.exe /Online /Disable-Feature:Microsoft-Hyper-V-All

PowerShell

Disable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V-All

Then I restart the machine, then I reinstall the Vmware workstation again and still it doesn't work.

Update: The operating System is windows 10

2
  • 1
    What edition and version of Windows 10 are you using? Edit your question to include this information. – Ramhound Jan 18 '18 at 17:15
  • 1
    I wanted to know what build (1703,1709, etc) and what edition (Home, Professional, Enterprise, etc) – Ramhound Jan 18 '18 at 20:34
4

Check the solution here: Cannot run VM in VMWare on Windows 10 due to Hyper-V

Some of Microsoft's security software (in the example above, DeviceGuard), uses the HyperV engine, so even though HyperV is disabled itself, the componenets are still being used.

You can only have one hypervisor at a time (it locks the Hardware Assisted Virtualization to a single one).

0
1

Thanks lot in my window defender following setting causing issue. window defender -> device security -> core isolation -> memory integrity = on turn of it for get rid.

Not the answer you're looking for? Browse other questions tagged or ask your own question.