1

I have a modem/router connected via PowerLine Ethernet to 3 different routers working as AP devices across our home. Occasionally (and especially when walking between different AP areas) the new, closer AP fails to give me an IP without switching my WiFi on and off a few times. Is this a problem with the DHCP leasing settings I have on my main router?

The main modem/router at 192.168.1.1 has its DHCP server range set from 192.168.1.2-192.168.1.99. Each of the other AP routers has their IP addresses manually set to 192.168.1.101, 192.168.1.102, 192.168.1.103 respectively, and their DHCP servers disabled. The WiFi network names and passwords are the same on all devices to create a continuous network throughout the house.

Each of these AP routers and the main router seem to function fine and provide internet access when tested in isolation, and I’m given an IP address in the range of the main modem/router (e.g. 192.168.1.4).

Thanks very much for your time.

1
  • According to this answer you should be fine having the same IP all the time. But check the "one roaming caveat" part. Is your problem like that? – Kamil Maciorowski Jan 18 '18 at 23:21
0

You have configured your network correctly in terms of IP addressing. Specifically:

  • All devices are using the same IP address subnetwork (I assume you're using the same subnet mask on all of them)
  • Your routers/APs have static IP addresses outside the DHCP address scope
  • Only one device is acting as a DHCP server

That leaves a few other possible problems:

  • The problem AP has an unreliable connection back to the cabled network. If so, your wireless devices can associate with it, but traffic cannot be forwarded to the rest of the network, including DHCP requests. You could test for this by setting up a continuous ping from the main router to the problem AP and observe whether any packets get lost. Another option is to set a static IP on a wireless device, start pinging the main router while wirelessly connected to it, then roam to the problem AP and observe whether you successfully associate, but the pings don't start going through.

  • There's wireless interference around the problem AP. This could be making it hard for devices to associate, stay associated, or communicate with the network once associated.

5
  • Your client might also be sticking to an AP that is too far away. You may actually need to turn down the power on some of them or , if available, increase the minimum acceptable data rate to 18mbps instead of 1mbps. Roaming is tricky, many people give up and setup seperate SSIDs. As a troubleshooting step you might want to test out how each AP behaves if they all have different SSIDs (and you repeat your walk). You want -67 dbm or better in most situations, if your client stays associated till -80dbm it might start failing to pass traffic reliably. – cloneman Jan 19 '18 at 1:05
  • 1
    @cloneman excellent point. I will try to incorporate that if you don't mind. – I say Reinstate Monica Jan 19 '18 at 1:06
  • No problem, I was also going to add that some cards have a roaming aggressiveness setting on the client side advanced properties, which is another potential button to poke with a stick. – cloneman Jan 19 '18 at 1:07
  • Thanks very much guys, I will try what you suggested. They are on the same subnet, yes, and are connected via Powerline Ethernet so I guess it’s very possible there is interference on that end but I note wired devices connected to other LAN ports on the various AP routers don’t seem to have this issue. If I can’t get it to work I might make 4 seperate SSIDs, which would be annoying but perhaps necessary. – Conor Jan 20 '18 at 7:34
  • Unfortunately my routers don’t have the option for a minimum acceptable data rate or for aggressiveness. Thank you for the suggestions however, it’s much appreciated. – Conor Jan 20 '18 at 7:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.