0

I have a Buffalo WZR-600DHP router running DD-WRT from the factory. I’ve enabled the following DHCP settings in Setup -> Basic Setup -> Network Setup -> Network Address Server Settings (DHCP):

DHCP Type: DHCP Server
DHCP Server: Enable
Use DNSMasq for DHCP: Check
Use DNSMasq for DNS: Check
DHCP-Authoritative: Check

I've also enabled the following dnsmasq settings in Services -> DNSMasq:

DNSMasq: Enable
Local DNS: Enable
No DNS Rebind: Enable
Query DNS in Strict Order: Enable
Add Requestor MAC to DNS Query: Disable
Additional DNSMasq Options: (NONE)

All of the machines on my local network show up in the Status -> LAN -> Dynamic Host Configuration Protocol -> DHCP Clients except for my router. From what I can tell, the names in this list are from the machines' /etc/hostname file, and I can ping them like so:

gamma:~ jrsmith3$ ping rpi.local
PING rpi.local (192.168.11.122): 56 data bytes
64 bytes from 192.168.11.122: icmp_seq=0 ttl=64 time=28.334 ms
64 bytes from 192.168.11.122: icmp_seq=1 ttl=64 time=7.644 ms
64 bytes from 192.168.11.122: icmp_seq=2 ttl=64 time=7.787 ms

However, I can’t see a hostname associated with the router itself; I can only access it via its IP address. I’ve noticed there’s no /etc/hostname file on the router itself when I SSH into it.

Is there any way to define a hostname for my router so I can access it without having to use its IP? I’ve tried googling but I only find results for setting the router up to perform DNS for machines on the local network — not how to set the router’s hostname.

Thanks!

Edits

Here's a similar question: DD-WRT: dnsmasq headaches with static hosts

  • Well it is running a DNS server right? Are you able to add a static DNS entry? – Appleoddity Jan 19 '18 at 2:04
0

The hostname setting is on the "Basic Setup" page under "Optional Settings" near the top, the same page as where you set the router's IP addresses.

Assuming other hosts can be resolved like shown, this should work. If not, you could add an entry to dnsmasq's configuration:

address=/router.local/192.168.11.1

Do note that using .local as your TLD may be undesirable as it can conflict with mDNS.

  • In Setup -> Basic Setup -> WAN Setup -> Optional Settings, I set Hostname = router and hit the "Apply Settings" button. I then tried $ ping router.local and got nothing. I then rebooted the router, tried pinging it, and still nothing. So I deleted the Hostname field and reset the router again. Next, in Services -> DNSMasq, I added address=/router.local/192.168.11.1 in the Additional DNSMasq options box. I hit the "Apply Settings" button, ping router.local, and nothing. I rebooted the router, attempted pinging it again, and still nothing. Is there a shell command I can use to diagnose? – joshua.r.smith Jan 20 '18 at 0:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.