6

So I'm having this issue with the really slow download speed and very fast download speed over cable and wifi. The network topology is the following:

Provider router and FO media converter (PON-TECH PT-47RW) in bridge mode => Asus AC-RT66U router (connected to lan 1 from provider router).

The speed tests I have done are the following:

laptop connected over cable to provider router - (73.44 Mbps download / 72.83 Mbps upload) http://www.speedtest.net/result/6983140310

laptop connected over cable to my asus router - (9.36 Mbps download / 64.59 Mbps upload) http://www.speedtest.net/result/6983164758

laptop connected over wifi to my asus router - (13.19 Mbps download / 42.59 Mbps upload) http://www.speedtest.net/result/6983158870

I have already tried other suggestions from various forums like turning off the firewall or WMM but that didn't help. I have also ran the tests using an old tplink TL-WR940N router and here's what I got:

laptop connected over wifi to my tp link - (21.81 Mbps download / 10.76 Mbps uplpoad) http://www.speedtest.net/result/6983146621

laptop connected over cable to my tp link - (12.51 Mbps download / 10.65 Mbps upload) http://www.speedtest.net/result/6983153018

The download speed over wifi is slighly faster but on cable is the same...

What could the problem be?

Summary
cable provider router - 73.44 Mbps download / 72.83
cable asus router - 9.36 Mbps download / 64.59 Mbps upload
wifi asus router - 13.19 Mbps download / 42.59 Mbps upload
cable tp-link router - 21.81 Mbps download / 10.76 Mbps
wifi tp-link router - 12.51 Mbps download / 10.65 Mbps

  • We don't want links to results in the question. Please edit and add a small summary table. – DavidPostill Jan 20 '18 at 18:41
  • Added a summary as requested :) – DSF Jan 20 '18 at 20:46
  • If you are running NAT on your router, disable that. NAT is resource intensive, and your provider router is already doing that. Double-NAT gives you nothing. In fact, you should probably disable routing (bridge mode) on your router. – Ron Maupin Jan 20 '18 at 20:49
  • Should I do that even if the provider router is in bridge mode? – DSF Jan 20 '18 at 20:55
  • I disabled the NAT but the internet stopped working. I believe that since the provider router is in bridge mode, it isn't doing any NAT-ing. – DSF Jan 20 '18 at 21:06
2
+25

In your ASUS Router Web Interface, under the Traffic Manager side menu item, is QoS enabled? if so, there are probably upload and download bandwidth fields. This could be the cause of your un-even throughput. Just turn off QoS on your ASUS router and run your test again. This is just an assumption because I don't have your router configuration file in front of me.

  • No, QoS is off. – DSF Jan 24 '18 at 10:16
0

After trying all suggested things and setups, I asked the provider to give me the WIFI password for their device and now I am using their device's wireless network and plugged out my ASUS router.

I concluded that the router-to-router connection isn't working very well or there is some sort of limitation in their device on using another router connected the PON-TECH one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.