0

I didn't know where else to ask this. What could have gone wrong with my USB hub for it to stop data and power transmission after I plugged in the auxiliary power adapter that it came with?

I have used this hub for about 7 months now without it's power adapter, it doesn't really have a brand, just 7 Port USB 2.0 Hub, sort of flat and silver looking. The DC5V light used to come on from the computer power alone, but after plugging in it's 5V 0.5A wall-wart power adapter, the hub ceased to function. At first my mouse was blinking red to signify insufficient power, and now nothing lights up, nothing gets power, and no data passes through the hub.

I thought at first that I may have opened the poly-fuse in the computer's USB port, so I changed ports with all the devices still plugged in, same problem. I unplugged it again, then unplugged every device and tried yet another port on the back of my computer, same problem there. So the problem isn't power surge, right? I checked my computer's event log, no mention of USB problems.

If it isn't power surge, I don't know what the problem is, especially since it stayed cold and made it through the last 7 months flawlessly. It's like the hub won't even turn on without the wall-wart, even so, no power or data transfer occurs with it plugged in.

  • "wall-wart" - What? – Ramhound Jan 20 '18 at 20:07
  • If the wall wart was rated 0.5A, it never should have been bundled with a 7 port hub because it can't provide the power requirement. See if the hub has a switch to select USB as its power source rather than the external adapter. If so, you can test the hub to see it it's working in case you can find a generic adapter cheaper than replacing the whole thing. Disconnect the adapter, set it to USB power, and see if any single port operates correctly. If so, the hub, itself, is fine. – fixer1234 Jan 20 '18 at 20:57
  • The hub has no switches, just a light on each port to indicate power being fed to them, and a light to indicate if it is getting power, either over the mini USB from the PC or from the aux PS. And no port is functioning anymore, likely something delicate inside blew when the voltage on the PS dropped under the load of 6 devices. Seems the PS it came with was faulty and I never knew because I never used it :/ – Sam Chamberlain Jan 20 '18 at 21:38
  • Before you bust open the hub, test it with a good external power supply. It's possible that, because it has 7 ports and can't work powered by its USB connection, it will only work with an external adapter. There might not be anything wrong with the hub. – fixer1234 Jan 20 '18 at 22:52
  • Turns out there was something wrong inside the hub, and it worked without the PS for 7 months including powering up a high quality Logitech webcam with it's own video compression chip. My dad and I opened both PS and hub, the hub had a blown diode, the PS was a crummy design. I posted an update down below, I thought it didn't fit to put it in the original post. – Sam Chamberlain Jan 20 '18 at 23:31
1

You can try to take a reading from your wall adapter with a digital multi meter. These style adapters should read a tad higher then the rated voltage. Something like 5.05v with no load. It shouldn't be dropping below around 4.90 at full load.

I don't have great luck with off brand accessories. A lot of them come from China with cheap components. You can open the hub and take a peak at the capacitors. If I had to guess it's some sort of component failure if the wallwart is testing out ok.

  • Ok, I did as you suggested, and I did what my dad suggested as well. The PS reads about 5.35V no load, under 50 mA draw which was a straight 100 ohm load it drops to 4.8V and stabilizes, under 500 mA draw it's rated safe limit which was a straight 10 ohm load it drops to a sad 2.7V. Might that have done it? – Sam Chamberlain Jan 20 '18 at 20:31
  • It shouldn't be dropping below around 4.90. if it is the wall-wart is damaged. And yes, under and over voltages can damage sensitive components. You can try a new 5v adapter if you have any spare ones. But I'm guessing the cost of buying a new adapter is probably pretty close to what it would cost on eBay to get another USB hub. – Tim_Stewart Jan 20 '18 at 20:41
  • I think my dad is locating a suitable PS in our basement and splicing the tiny barrel connector onto it. I guess with many Chinese devices, it's luck (more like unluck) of the draw, just seems I get faulty ones more often than others :/ – Sam Chamberlain Jan 20 '18 at 20:57
  • Your not alone there. FYI it helps to put this kind of stuff on a ups (uninterruptible power supply) it saves a lot of sensitive intergrated controllers from surges/spikes. Hope this helped! – Tim_Stewart Jan 20 '18 at 21:00
  • Yeah it did, thanks! Oh, and my dad has several UPSs in out basement, but they are all filled running more critical devices like our phone system, home ethernet network, and internet service devices like the routers and wireless access points. I should really buy myself a UPS, then again getting a good laptop for college mechanical engineering is top priority :) – Sam Chamberlain Jan 20 '18 at 23:35
0

I didn't think this fit in the original question so it's going here.

My dad and I did a voltage reading on the ports of the USB hub and it's ports read 2.4V, no load. No wonder why the LEDs weren't lighting up, they need 5V to work. Just to make sure it was reading correctly, we tested my PC's USB ports, each giving the normal 5V or just above, dropping to around 4.95V under full 500mA draw. The hub, we didn't bother testing under load, because that would be pointless since it would just drop farther.

Currently the hub is going to the basement for my dad to replace the blown components, along with witnessing the engineering that went into the hub. Funny, it was a nice aluminum encased hub, albeit without the proper input protections, with a very crummy and dangerous power supply. What a combo :/

EDIT: He opened the hub and it looks that the diode that combines PS power and USB power blew open. Also, the design is really nice inside, large bypass capacitors to clean up all the noise, a strong and capable microcontroller, gold plated vias, but it's really messy, with leftover flux on the board and stray solder in a couple places on the mask from the wave soldering process. One of the capacitors' leads was slightly melted as well for some reason, the only port that was left unused, and the mini USB port that connects to the PC was a bit rusted too. I guess now I know now why my dad is a big name on EEVBlog :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.