50

I have plugged a second screen into my laptop and now the text is blurry but only on the second screen. The effect is not visible for all applications. I am on Windows 10.

How do I fix this?

2
  • 1
    I had this problem. I think it's because I had different display scaling on each monitor. I set both to 125% and now text is crisp on both displays now. Oct 10 '20 at 14:44
  • This also worked for me. Scaling at 125% on both fixed the blur on the external monitor. I had to adjust the font size on the IDE I was using to match the laptop and the zoom on the web browser also.
    – Jeffrey
    May 17 '21 at 15:56

12 Answers 12

32

Windows 10 still can't do scaling properly. But there is a workaround for this.

  1. Connect the external display.
  2. Go to display settings and set your screen with lower DPI that has 100% scale factor as the primary screen (there is a checkbox at the bottom of this screen).
  3. Log out and log in. Now both screens should have crisp text.

If you disconnect external display you'll get blurry text on the laptop, but don't worry - if you log out and log in it should be fixed. If you connect monitor, you need to log out and log in again. It is annoying, but I did not find a better way and Microsoft just doesn't care.

2
  • 3
    It didn't work for me. I set my external monitor as primary screen (which I didn't want to but I did anyway). Doing so makes text blurry on my laptop built in display.
    – shashwat
    Feb 4 '19 at 9:24
  • that solved the blurry texts but thats not a good option for me, because it moves the taskbar with time and notification icons to the other display as well 😫
    – denns
    Jan 22 '20 at 9:21
18

Solution 0

It could be a not optimal default configuration applied by your monitor after to plug in to your pc. So before to change your system settings, try to auto configure your monitor via monitor's menu/buttons.

Solution 1

To fix this issue, please check Start => Settings => System => Display tab

Find the Scale and layout section and set the value of scaling at 100 % for each monitor Indeed, the scaling op the text can occured an blurry appearance.

WARNING : You must do these operation for each monitor (select the monitor 1, set the correct value then select the monitor 2 set the correct value, ...)

Solution 2

If you want scale the text, you can do but you must disable the display scaling on high DPI for each app who doesn't display correctly. To do that, You must find the exe of the application. Tips : to find easily the exe, right click on the app => properties => Open file location.

Do the following:

  • on the exe, right click
  • troubleshoot compatiblity
  • Troubleshoot program (second option) =>
  • Check "The program open but doesn't display correctly"
  • Next
  • Check "Program does not display properly when large scale font settings are selected"
  • Test the program...
  • Next
  • Yes, save these settings for this program

If you want to do, you can use The process explorer and add the column dpi aware to help you. This tools is avaible on the Microsoft sysinternals webiste.

Et voilà :)

This is the the explanation that you can find on the microsoft documentation

Windows® desktop apps fall broadly into two classes: apps that are DPI-aware and those that are not.

However, if an application is not DPI aware, and is running on a high DPI display, Windows scales the app by applying bitmap scaling to the application output. This ensures that the application is the correct size on a high DPI display. In most instances this will result in crisp and usable applications, but in some instances, the result is less crisp and might have a slightly fuzzy or blurry appearance because of the bitmap scaling.

3
  • 2
    Thank you! Solution #2 worked beautifully and now my putty window is sharper than sharp.
    – Endyd
    Feb 28 '20 at 14:06
  • Solution 2 (for support.microsoft.com/en-us/topic/… ) leaves the Office apps small / unscaled but at least crisp... allowing to zoom into the files... sup-optimal but may be the best of bad options (re-starting Windows as a workaround works, but is not a good options for me as I frequently disconnect the external monitor when on the move). Apr 21 '21 at 10:52
  • Would be great if you could add a brief description of how to "undo" solution 2 for a given program, thanks! Apr 21 '21 at 11:10
7

You can try to use a different high-DPI compatibility setting for that app instead of the Let Windows try to fix apps so they’re not blurry setting.

  • Enter the name of the program in the search box on the taskbar, right-click the search result, and then select Open file location.
  • Right-click the program, select Properties, and then select the
  • Compatibility tab. click Change high DPI settings
  • Select Use this setting to fix scaling problems for this program… check box
  • Use I signed in to Windows option
  • Select the Override high DPI scaling behavior check box
  • Use Application option
  • Press OK and OK . Then Restart the program

References :-

3
  • I don't see this option, am i on old version of windows? 1709?
    – Zeus
    Feb 13 '19 at 17:52
  • 1709 also has that option! @Zeus Feb 14 '19 at 5:20
  • @Zeus - you need to right click on the opened application in the toolbar, and then right-click again on the instance of that application to see the properties option
    – cbcoutinho
    Apr 25 '19 at 23:04
2

In case this helps anyone else, I experienced the same symptoms as rdhainaut driving a pair of Dell U2419H monitors from an XPS 15 (9560) laptop through a WD15 dock with single Display Port output and the second monitor chained to the first via DP.

The second monitor was blurred with migraine inducing vibration on the text.

Solution for me came through the Intel HD Graphics Control Panel which allows the refresh rate to be set for each monitor and importantly offers choices including 60i Hz and 60p Hz corresponding to interlaced and progressive.

My primary display was on progressive and the secondary on interlaced. Matching the setting for both displays resolved the blurred/vibrating text. Full process was

  1. rClick Desktop > Intel Graphics Settings
  2. Display > General
  3. Select Display > Digital Display
  4. Set Refresh Rate: Select 60p Hz

Repeat steps 3 and 3 for Digital Display2.

1
  • I didn't use the Intel Control Panel, but adjusting the Refresh Rate was the fix for me as well.
    – tylerwal
    Dec 11 '19 at 3:02
2

I was able to fix this very easily by doing the following:

  1. Right-click on the desktop on one monitor and select Display Settings
  2. Click Advanced Scaling Settings
  3. Turn off Let Windows try to fix apps so they're not blurry
  4. Repeat steps 1-3 for the second monitor

I think Windows has an issue with having the above fix blurry setting on for 1 monitor and not the other where the monitor resolutions are different for each monitor. Hopes this helps someone.

2
  • The text under the "Let Windows try..." checkbox specifically says "this will only work for applications on your main display". There is also only one instance of that toggle, it doesn't matter which display is selected prior to clicking "Advanced Scaling Settings".
    – apraetor
    Mar 18 '20 at 21:48
  • worked for me after restart, thanks!! Aug 28 '21 at 1:17
1

I had similar issue with a blurry screen when connecting in Windows 10 wirelessly to another laptop screen, extended mode.

The wireless display was scaled to 85% with an unnecessary black border around.

The issue was with the Intel Graphics Settings.

Steps to solve it:

  • Right click Desktop > Intel Graphics Settings
  • Display > Wireless Display
  • Picture Size <-- change to 100%
1

Apart from all other solutions mentioned, the following worked for me:

Switch the external monitor (that shows blurry apps) as your main monitor'.

STEPS:

  • right click on desktop and click 'Display settings'
  • Select the external monitor and check the 'Make this my main monitor' checkbox
0

Had The same problem. I solved it by replacing the vga cable with an hdmi one.

In my case the point was that windows wasn't properly recognizing mi monitor aspect ratio, that actualy was 16:10 and, for this reason, it was only offering resolutions suitable for 16:9 displays. I figured this out setting the resolution to a value higher than the supported one, then monitor was asking for a 1920*1200 resolution while in the windows settings page there was only the wrong ratio 1920*1080. I also noticed that in this case windows wont mark none of the resolution available as the 'recommended'.

0

This solution is based on hints from the solution posted by @rdhainaut. His "Solution 2" worked for one app, but I did not want to do it for every app individually so I guessed that the global setting must somehow not be taking effect.

Here is what worked for me

  • Set scaling to 125% for ALL monitors, including the laptop screen (1)
  • Restart computer
  • Set scaling to 100% for all monitors
  • Restart

Now all good.

(1) Display Settings -> Scale and Layout -> "Change the size of text, apps and other items"

0

A very overlooked solution is to turn the sharpness way down, to less than 10. That along with the other suggestions here, like turning off all the post-processing settings on the tv, helped as well- overscan off, adaptive contrast, etc.

-1

To fix this issue, please check Start -> after that Settings => after that System => after that Display tab Verify the drivers to be installed

-1

In case this helps anyone...

When I changed from HDMI2 to HDMI1, the image got better. Probably the HDMI2 input was somewhat broken. I'll never know for sure. Sometimes you are just blaming the wrong thing...

Not the answer you're looking for? Browse other questions tagged or ask your own question.