2

I'm trying to install Docker but unfortunately Windows decided that I'm not going to do that. In order to get it working, I have to activate the Hyper-V feature. I tried using GUI and Powershell using the Enable-WindowsOptionalFeature -Online -FeatureName:Microsoft-Hyper-V command but everything I get is this. The referenced assembly could not be found. Error 0x80073701. How do I fix that? Thanks!

PS: My computer can run Hyper-V and the relative options are activated. Windows version is Windows 10 Enterprise LTSB.

8
  • Use the current LTSB ISO as a source – Ramhound Jan 20 '18 at 22:33
  • Excuse me, what do you mean? – Cris Jan 21 '18 at 0:13
  • You can indicate you want to use an mounted .wim as a source to install the feature your trying to install – Ramhound Jan 21 '18 at 1:01
  • Okay, I mounted my OS iso and went through this guide support.microsoft.com/en-gb/help/2913316/… thinking it could work on Windows 10 too but... powershell returns "The target of the specified cmdlet cannot be a Windows client-based operating system." – Cris Jan 21 '18 at 12:09
  • Tried also with the Enable-WindowsOptionalFeature command but "The referenced assembly could not be found." – Cris Jan 21 '18 at 12:48
0

Solved! Evidently my system lacked some updates. I mounted the Windows ISO file and ran the setup.exe contained in the root directory. I let it do its stuff and then I could activate Hyper-V.

0

The following solution was good to solve this trouble of missing assembly on my computer

https://www.sysnative.com/forums/threads/windows-10-pro-error-error_sxs_assembly_missing-installing-hyper-v.28843/

1
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – Tetsujin May 25 '20 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.