0

I am (unfortunately) using a Mac with macOS High Sierra 10.13.2) and I am trying to mount an external disk in vfat format.

First I check the identifier of the disk using diskutil list where I see the following:

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *251.0 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         250.8 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +250.8 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD            120.7 GB   disk1s1
   2:                APFS Volume Preboot                 18.7 MB    disk1s2
   3:                APFS Volume Recovery                506.6 MB   disk1s3
   4:                APFS Volume VM                      3.2 GB     disk1s4

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *1.0 TB     disk2
   1:             Windows_FAT_32 LACIESHARE              1.0 TB     disk2s1

Then I tried to mount the disk disk2s1 to the folder Lacie as follows:

>sudo mount -t msdos /dev/disk2s1 Lacie/
mount_msdos: /dev/disk2s1: Resource busy

I also tried a diskutil command without success:

>diskutil mount -mountPoint Lacie/ /dev/disk2s1
Volume on disk2s1 failed to mount

The disk itself is fine, automounts on Linux and Windows systems without any problem. So, how can I mount a simple external disk on a Mac...?

4
  • It ought to just mount as soon as you plug it in, no need for terminal at all ordinarily. Tried rebooting, reconnecting? – Tetsujin Jan 21 '18 at 9:34
  • Yes tried it all. Does not automount. Maybe its not possible with a Mac? – Alex Jan 21 '18 at 10:31
  • I reconnected the drive a couple of times, and it was not being recognized. Now I just did it again, and now it worked. So I just have to try dozen of times? Thats all I can do...? – Alex Jan 21 '18 at 10:44
  • 1
    Maybe vfat is changing how it's 'thinking' but really it ought to "just work", HFS, FAT16/32, NTFS, shouldn't matter. – Tetsujin Jan 21 '18 at 10:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.