-1

I turned off all Windows Defender settings on my Windows 10 VM, but real-time protection kept re-enabling itself. I then found a registry setting to turn it off for good, but now Windows Defender Antivirus Service consumes tons of memory (>3GB).

I reverted the change, but it's still taking tons of memory (>800MB). I think the drop is related to reverting the registry change, and re-enabling real-time protection, but it would be great to actually turn it off.

enter image description here

  • Install a different antivirus program, and Windows Defender will be disabled. – Michael Hampton Jan 17 '18 at 18:31
  • @MichaelHampton I started looking into that; I'm concerned I'd end up making things worse. – MStodd Jan 18 '18 at 17:43
  • You're not really trying to have no AV, are you?! – Michael Hampton Jan 18 '18 at 18:32
  • @MStodd - You may like to upvote the answer if it helped you! Please see how to upvote an answer here -> meta.stackexchange.com/questions/173399/… You may also like to accept the answer if it helped you! Please see how to accept an answer here -> meta.stackexchange.com/questions/5234/…. – Am_I_Helpful Jul 31 '18 at 17:18
2

I'm not aware of the setting which is to be done through regedit, but I can comment about disabling it using the Group Policy.

Please follow the steps in the order as listed below:

  1. Go to "Run". Type "gpedit.msc" and press Enter. A window titled "Local Group Policy Editor" will launch.

  2. Go to Computer Configuration on the left pane, and then double click on "Administrative Templates".

  3. Once Administrative Templates gets expanded, then go to "Windows Components" and double-click/expand the item.

  4. Inside Windows Components, go to "Windows Defender Antivirus" and double-click the folder.

  5. Once expanded, the settings for the Windows Defender Antivirus will be visible on the right-side as shown below.

enter image description here

  1. Next, you can launch the "Turn off Windows Defender Antivirus" option -> click on "Enabled" -> Click on "Allow" -> Click on "OK".

enter image description here

-> Voila, that's it. Your Windows Defender Antivirus should stop working as described in the image and listed below.

If you enable this policy setting, Windows Defender Antivirus does not run, and computers are not scanned for malware or other potentially unwanted software.

NOTE: Please note that if you've a group policy in effect which is controlling this Setting, then it'll restore the default settings, OR may not allow you to make any changes. You may need to confirm the same from the System-Administration team, or whoever looks after the ADS, if that be the case.

  • I second this. Another guide - borncity.com/win/2017/04/19/… – Mr. Raspberry Jan 16 '18 at 12:43
  • I have this policy enabled, but it no longer stops the Windows Defender Antivirus Service. – RomanSt Nov 27 at 12:44
  • @RomanSt - Your case looks very strange! What I quoted is as per Microsoft official policy document. If you're finding any different behaviour, I'd suggest you to please raise a ticket and coordinate with Microsoft support. Ideally, in my opinion, it should have been disabled after configuring the said setting! – Am_I_Helpful Nov 27 at 13:02
1

Run regedit.exe, go to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows Defender, create a DWORD DisableAntiSpyware and set it to 1:

enter image description here

After reboot, Defender is fully off.

Not the answer you're looking for? Browse other questions tagged or ask your own question.