16

I have a computer running Windows 7 that shares a Git repo on drive D. Let's call this PC "win7". This repo is the origin of a project that we push to and pull from.

The network is a wireless network. One PC on this network is running on Windows 10. Let's call this PC "win10". Win10 can ping every other PC on the network including win7. Win7 can ping win10. Win7 can access all shared files on win10. Neither of the PCs have passwords.

Problem: Win10 cannot access any shared files on win7, not from Explorer, nor from Git Bash or any other Git management system (E-Git on Eclipse or Visual Studio). So, win10 cannot pull/push. Every other PC on the network can access win7 shared files and push/pull to/from the shared Git origin.

What's wrong with Windows 10?

I have tried these:

  1. Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings\ File sharing is on, Discovery is on, Password protected sharing is off

  2. Adapter Settings\Properties\QoS Packet Scheduler uninstalled and re-installed

  3. Adapter Settings\Properties\File and Printer Sharing uninstalled and re-installed
  4. Adapter Settings\Properties\EVERYTHING uninstalled and re-installed
  5. gpedit.msc\Computer Config\Win Settings\Security Settings\Local Policies\Security Options:

    Enabled These:

    • Network access: Allow anonymous SID/name translation
    • Network access: Let Everyone permissions apply to anonymous users


    Disabled These:

    • Network access: Restrict anonymous access to Named Pipes and Shares
    • Network access: Do not allow anonymous enumeration of SAM accounts
    • Network access: Do not allow anonymous enumeration of SAM accounts and shares
  6. netsh int ip reset, and then restarted

  7. netsh winsock reset, and then restarted
  8. AdapterSettings\ Enabled NetBIOS over TCP/IP
  9. Tried changing to static IP
  10. The new windows 10 Control Panel\ Network Reset
  11. Firewall is turned off

All of these were tried to no avail.

16
  • 1
    So what have you tried to enable file sharing on the Windows 7 machine? Have you tried HomeGroup yet? Jan 22, 2018 at 12:15
  • Are the user names and passwords the same between the computers? Jan 22, 2018 at 14:24
  • You haven't told us exactly what happens when you try to access Win7 from Win10. Do you get an error? Jan 23, 2018 at 4:30
  • @Sonickyle27 Edited the question Jan 23, 2018 at 5:13
  • @AllenHoward Neither of the PCs have Passwords. Jan 23, 2018 at 5:14

1 Answer 1

24

AT LAAST!! After 4 month, and seeing the error for the second time, I found the solution here:

https://support.microsoft.com/en-us/help/4046019

Turns out, if you type the ip in "Run", and only in "Run", a very specific error shows up that contains this message: "your organization's security policies blocks access..."

Searching that lead me to this solution:

Open "Local Group Policy Editor" by searching in Start Menu or going to Run and running gpedit.msc, then go to Computer Configuration\Administrative Templates\network\Lanman Workstation and: "Enable insecure guest logons"

And that solved the problem.

9
  • 1
    Isn't this the same as "Turn off password-protected sharing"? May 27, 2018 at 10:21
  • 1
    i.imgur.com/psYm79w.png May 27, 2018 at 10:22
  • 1
    Unfortunately, and speaking from two times experience with this problem, no, in both times the password protected sharing was turned off. May 28, 2018 at 16:00
  • 1
    I would say, if you ever ran into this problem and password protected sharing was already turned off, pay the ol "Lanman" a visit :) May 28, 2018 at 16:01
  • 1
    Could you please elaborate how you got access to Computer configuration\administrative templates\network\Lanman Workstation . Have exact same issue after win10 crash
    – Nightwolf
    Jan 17, 2019 at 7:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.