3

I'm running Windows 10 Insider Preview Build 17074 for PC. The Windows Subsystem for Linux is enabled and I've installed Ubuntu on Windows from the Windows Store.

Whenever I try to launch Ubuntu, it fails with the following error message:

"The data area passed to a system call is too small."

enter image description here

I've tried uninstalling/installing the app (via Apps & features) and disabling/enabling the Linux Subsystem (via Turn Windows features on or off), but still get the same error.

How can I fix this problem?

Windows version

Error message

Install Ubuntu

Uninstall Ubuntu

  • I haven't seen this, but I did remove WSL before installing Ubuntu on Windows. I don't know if there is a conflict between the two versions, but I suggest you remove both before installing Ubuntu again. – AFH Jan 24 '18 at 11:24
  • 1
    17074 Isn’t 1709 that’s a Insidsr Preview build for RS4 which would be more like what will become 1803. – Ramhound Jan 24 '18 at 12:12
  • "I've tried uninstalling/installing the app and disabling/enabling the Linux Subsystem, but still get the same error." - This doesn't reset the environment. How did you uninstall the application exactly? Edit your question. – Ramhound Jan 24 '18 at 13:09
  • 1
    Try running wslconfig /unregister Ubuntu in an elevated PowerShell prompt. However, worth pointing out, the directory stated in the error, does not appear to be correct. This might have to do with the fact you are on a Slow Insider Preview channel. – Ramhound Jan 24 '18 at 16:19
  • 2
    update to Build 17083 and look wha happens. Insider Version tend to have more issues compared to stable Versions. – magicandre1981 Jan 31 '18 at 16:12
3
+50

As mentioned in the comments, you use an Insider Preview Build 17074 of the next Feature Update:

enter image description here

In this preview Version, Microsoft makes a lot of changes and bugs are expected. So try lastest Windows 10 Insider Preview (as of writing this is Build 17083) and look if the issue is fixed. If not, report the issue to Microsoft via Feedback Hub App.

Backup all data and go to the stable Windows 10 Fall Creators Update v1709 (Build 16299) by doing a clean install via 1709 ISO. Now install the Linux Subsystem again and use Ubuntu. This should be stable.

  • 1
    This error logged in GitHub. You can't solve that by clean installing. Link. – Biswapriyo Feb 2 '18 at 13:16
  • @biswapriyo Thanks for the link, change your comment to an answer and I'll accept it. – Luke Girvin Feb 5 '18 at 12:11
  • @LukeGirvin That is not an answer. And I don't know about that problem so much. If I know details I'll definitely do that. – Biswapriyo Feb 5 '18 at 13:04
0

This turned out to be a bug which occurs when SQL Server is running with the filestream feature enabled, as described in this blog post:

Simply speaking, this issue occurs due to due to miscommunication between two filter drivers, namely WCNFS (the desktop bridge) and RsFxXXXX.sys driver (filestream system driver). RsFx system driver doesn't honor flags being passed by WCNFS driver appropriately, which causes startup failure of any Centennial application with the aforementioned error.

Stopping the SQL Server service let me run Ubuntu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.