3

I have Windows 10 Home Build 16299

I am having serious problems with my internet connection. I keep losing the internet on the computer. It shows the connection to the wifi but says "No Internet Connection". If I then disconnect from the wifi and reconnect to it then all works great. It does not seem to be a problem with the wifi itself because my phone has no such problem.

My connection is through a range extender but the same happens when I am not through the extender.

I have tried updating my drivers but nothing seems to help.

Edit: It doesn't seem to happen when I connect to the internet by using my phone as a hotpoint.

2
  • I've had related problems when trying to connect Win10 systems via WEP (which I need in order to support legacy devices). My solution is to use a mains range extender with a separate network configured for WPA. If you're using WPA, you can ignore this comment.
    – AFH
    Jan 24 '18 at 12:46
  • @AFH Sadly, I am already using WPA2
    – theblitz
    Jan 25 '18 at 12:00
1

Try downgrading (rolling back) Wi-Fi driver as well. If it won't help, try connecting via cable (if you have an Ethernet NIC) or USB Ethernet NIC. If your connection is lost even when you're on the cable, try these steps. If you're experiencing problems only with Wi-Fi, try another Wi-Fi adapter (USB Wi-Fi for example) and see what happens.

2
  • AFAIK, it doesn't happen when connected by the cable but it is hard to be sure because it is intermittent.
    – theblitz
    Jan 24 '18 at 11:33
  • Made a small edit to the question adding bit more information.
    – theblitz
    Jan 24 '18 at 11:35
1
  • Open the command prompt and type "ipconfig/all".
  • Check the results on both scenarios: when your internet is working and when it's down.
  • Compare the results to see what's different.
  • If it's the same problem as mine, you will notice that when there is no internet, there are multiple "Wireless LAN adapter Local Area Connection" with the description "Microsoft Wi-Fi Direct Virtual Adapter #". It can be #3, 4.... Take note of the ones that do not appear when the internet is good.
  • Now go to Device Manager, click on "Network Adapters", find the ones that only appear when the internet is down, right click and select "Disable Device".

If you don't find the adapter is because it's hidden. In that case must go to View (on top) and select "Show hidden devices". Then select the device and disable it.

After that, if your internet is down, you can reset your network adapter (or just right click on the internet icon and select troubleshoot problems) and it will not disconnect again.

Hope it saves you the time it took me to find out and get it fixed. I actually did it a while ago, but today, after a windows update, I got the same problem again... and decided to write it down.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.