0

I have a 3 years old Dell XPS 8700 (SSD 256, HD 3TO, 32G Ram, Intel I7) shipped with Windows 8 and subsequently upgraded with Windows 10. I have recently installed Ubutuntu 17.04 which seemed to work properly.

Today My computer froze and I tried to reboot it. Though Once in grub, whether I choose Windows or Ubuntu I get a blackscreen.

I tried to log from a USB stick with a version of Ubuntu 16.04. I selected "try Ubuntu" but then again black screen.

From the grub I tried "check disk errors" but failure again. Dell Bios diagnostics show no problem. (Though I suspect something is faulty somewhere or maybe SSD is dead or some corrupted data) Also I tried to Boot directly into Windows from the Bios and bypass Grub, which gave me Windows Recovery (though I have never made a recovery disk) and cannot go further here.

My concern at the moment would be to retrieve some files on SSD disk which holds the Windows partition. The best would be to boot Ubuntu from a USB disk and migrate important files to HD before attempting things on the SSD ? Otherwise should I just remove the SSD and recover through an USB3 adapter ?

And then maybe wipe it and try to reinstall Ubuntu (my Windows is OEM so no install disk at hand and I don't mind having Ubuntu only)

3
  • Did you recently install a BIOS patch or update, like in the last 2 weeks? – music2myear Jan 24 '18 at 16:10
  • It goes in the back but I don't think I did. Bios shows a date in 2014. Also I managed to have Ubuntu splash (from stick) but it is failing shortly after. Some list of errors flicker for a few milliseconds and mentions "Radeon", so maybe my card is dead. Then a square of color shows on the top right corner and nothing. – Maxence Jan 24 '18 at 16:27
  • Can you boot into the BIOS? Check your settings there? – music2myear Jan 24 '18 at 16:29
1

The machine should boot from a USB flash or external HDD even if there were no SSD or HDD. If, as you state, "I tried to log from a USB stick with a version of Ubuntu 16.04. I selected "try Ubuntu" but then again black screen," then the issue is not with the SSD, but with hardware or the UEFI/BIOS boot setup, most likely the display setup.

8
  • 1
    Actually, the XPS line comes with high-end Nvidia graphics for which it's often needed the additional boot parameter nomodeset until the Nvidia drivers are installed. – user772515 Jan 24 '18 at 16:37
  • Yep on my Dell laptop I have a USB stick and some Linux distribution requires nouveau.nomodest=0 but this desktop never complained when i installed Ubuntu 17.04. Though now I see Ubuntu start (on stick) and it fails with some error message flickering about "Nvidia" . Then I see a big colored squared on top right then nothing. Thanks Dr Moishe, I am going through the checks now. – Maxence Jan 24 '18 at 16:58
  • @Michaelbay you are correct, nomodeset does boot into the stick. Great. I can see my drives. HD is fine. though when i click on the SSD (with Windows parititon only) it gives me this : Error mounting /dev/sdb5 at /media/ubuntu/OS: Command-line 'mount t "stfs" -o "uhelper=udisk2,nodev,nosuid,uid=999,gid=999" "/dev/sdb5" "/media/ubuntu/OS" exited with non-zero exit status 14: Windows is hibernated, refused to mount. Failed to mount '/dev/sdb5': Operation not permitted The NTFS parition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting),... – Maxence Jan 24 '18 at 17:31
  • @DrMoishe Cell seems good but I have replaced CR2032 as it was 4 years old. I removed graphic card and reinstated. Also removed msata hard drive and dusted. All back in place. I have not yet performed the two last checks with the bios but once Ubuntu stick is loaded, I egt above comment error when trying to access SSD – Maxence Jan 24 '18 at 17:33
  • @Maxence That's entirelly expected due to the Fast Startup feature of any Windows 8 or newer. (NTFS) drives are semi-hibernated just like the message says. – user772515 Jan 24 '18 at 17:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.