1

I use Win7 Ultimate 64-bit on a Thinkpad t440p. This morning Windows Update prompted me to install KB4054852 and KB4054981. So I did, after restarting I checked Windows Update and found that it was throwing error 8024000E saying it can't get updates now. I tried the steps listed here:

How do I reset Windows Update components?

But I was not able to complete all of the re-registers list in step 6 because most failed. However I completed the instructions and restarted.

The error went away and I was prompted to install 5 very old updates. I installed them assuming that I'd need to reinstall all of them but windows seemed satisfied after those. After about 30 minutes of normal use my machine crashed with BSoD listing BAD_POOL_HEADER as the cause. IDK if that is connected but after windows finally rebooted windows update now states it can't search for new updates code C80003FA.

Does anyone have a solution for this that they have tried and actually works?

EDIT:

These where the only things I was able to re-register from step 6 in the link above:

  • regsvr32.exe atl.dll
  • regsvr32.exe urlmon.dll

After attempting the steps listed in the link above and restarted my machine my Windows Update history was totally blank that's when I was prompted to install updates the older updates. I don't know which updates they were because when I check my update history now It says that I'm current. Check this screen-cap for the latest listed; win update scr shot

9
  • What was the most recent update that was installed successfully? You mentioned most of the "re-registers" failed, which failed, be specific. Which "very old" updates did you install specifically? Edit your question. Do you have KB4033342 installed? I cannot find a support article that mentions KB4054981. What is the description for KB4054981? – Ramhound Jan 24 '18 at 18:59
  • KB4054981 appears to be a preview patch of a quality update The fact both were installed seems odd. – Ramhound Jan 24 '18 at 19:04
  • Question has been updated. Should I uninstall KB4054981? – James Draper Jan 24 '18 at 19:14
  • I assume you have tried to reboot? – Ramhound Jan 24 '18 at 19:17
  • Yeah, I've tried that. – James Draper Jan 24 '18 at 19:19
0

I uninstalled KB4054852 and KB4054981 and rebooted that seemed to fix the problem.

The BSoD due to BAD_POOL_HEADER appears to be from a bad RAM module.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.