2

I am using remote desktop to connect to a server. Both the client and server are within the same corporate network.

  • The client machine is running Windows 7 Professional
  • The server is running Windows Server 2012 R2 Standard

On the old server (Windows Server 2003), connecting via remote desktop would ask for the password before connecting , and then log straight in without asking again.

On this new server (which is more tightly controlled by IT services), the remote desktop client asks for the password before connecting, but then I am presented with the login screen on the server and I have to login again (using exactly the same account).

Apparently the RDP client is meant to forward the password to the server, but due to security settings on the server this has been disabled. I have tried to get this fixed but to no avail.

What I'm asking now is, why does RDP ask for the password before connecting, and how do I disable this?

I've tried setting Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Connection Client -> Prompt for credentials on the client computer to Disabled in the Local Group Policy Editor, but that hasn't helped. Is this setting being overridden by the domain policy?

  • Run gpresult and it should give you an idea whenever it's overwritten or not. – Seth Jan 25 '18 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.