4

I'm baffled, as the title says, the auto detection just doesn't work. I can manually change the language of any given email, but it won't autodetect. The languages are pretty different, so it shouldn't be that hard...

Anyone had any similar problem?

Pretty irritating, as I use the languages 50-50...

Though below image has 2 languages in one document, the detection doesn't work on single language emails either. Full Hungarian or full English - still no successful detection.

Whatever I set as default is used from then on in all documents, regardless of the language of the current document.

Autodetect doesn't work

2
  • Have you tried with more that one statement/longer text? Sometime it can require more words (also time) to tune on the language, where it is set to autodetect – Menion Jan 25 '18 at 15:26
  • That's curious. If I copy-paste a long Hungarian text, the second part of it is immediately recognized. The first stays "English". If I copy-paste it in bits, it is not recognized (even after 5 minutes). This just made everything more confusing. Wow. Maybe I'll do a bug report. – vacip Jan 25 '18 at 15:39
7

Edit: Scroll down for solution.

I can confirm that the Microsoft Outlook's feature "Detect language automatically" works only under special circumstances. Once per e-mail. There are 3 preconditions:

  1. Set the default language to other than English (Review > Language -> Set Proofing Language...> [Select language] > Set As Default)
  2. Start writing in language that is not English with correspondingly selected keyboard layout
  3. Switch the keyboard layout (Alt + Shift or Win key + Space in Windows) before writing in English.

The following image shows and explains the steps performed. Outlook proofing language test

So basically, you can write in one language and then switch to English once. If you want to write again in the previous language you can copy-paste the text or just one character from before or use the menu to set proofing language.

By the way, the signature has automatically "Do not check spelling or grammar" property set so if you select and delete it, the proofing for following text won't be enabled unless you set it manually.

Workaround

Other than with the conditions mentioned above, the fastest and most reliable option for multiple language proofing in one e-mail (so far) is by setting the language manually. To have the button easily accessible:

  1. Right-click on the Ribbon bar > Customize the Ribbon... (Or go to Outlook options: File > Options > Customize Ribbon)
  2. On the right pane press New Group (Optionally rename it to e.g. "Language")
  3. On the left pane select in Choose commands from: "All commands"
  4. Scroll to and select "Set Proofing Language" command and press "Add" button or drag and drop it in the newly created group.

Outlook options

Press "OK" and you will have the "Set Proofing Language" easily accessible from the Ribbon bar so that each time before you need to write in different language (other than default) you can select the proofing language with 3 clicks.

Solution

Apparently it boils down to the Windows Language settings: If you have just one language installed (e.g. English) with multiple language keyboard layouts in Windows Settings, the proofing tools won't recognize the text correctly automatically.

To let proofing tools recognize the text in each language you need to have the language installed, not just the keyboard layout. To do that (on Windows 10) go to Windows Settings (Win key + i) > Time & Language > Language > Add a language > [select your language] > Next

From the Install language features window just the "Basic typing" option is sufficient. Press Install.

Windows Language settings

To test open a New Email window in Outlook (Ctrl + N) and start typing in your selected language. Now switch to different language by pressing Alt + Shift or using the language selection menu near the clock in the Windows taskbar:

Language selection menu

The proofing tools should work automatically:

Proofing tools working correctly in Outlook for Office 365

Note that each pair of words is written in different selected language and automatically (without touching the mouse) recognized by proofing tools. (1st line: English, Latvian, German 2nd line: German, English, Latvian)

Note - two things to bear in mind:

  1. If you have enabled default Signature for new e-mails in Outlook options (File > Options > Mail > Signature...) or add the signature manually (through Insert > Signature) before writing any text and start writing a new e-mail in a language other than the default in your Outlook settings, it won't be recognized correctly regardless of the currently selected language in your Windows language menu. To work around that just simply cycle through (Alt+Shift) your languages one time.
  2. There is a small delay after selecting different language for the first time. If you start typing immediately after switching language the proofing tools might treat the text as in previously selected language. To avoid that just wait a second before starting to write in a new language for the first time.
2
  • Looks like I finally have found a solution - I have updated my answer. – KristoZ May 29 '19 at 12:16
  • 1
    You deserve far more reputation than I can give you! – freefaller Jul 9 '19 at 9:49
0

This because the spell checker and syntax highlight can work for only one language per document (doc, email, whatever office file). You cannot mix two languages in the same email/doc and have the checker to follow your mixture

2
  • Sorry, the picture was a bad example then. It doesn't even detect full Hungarian / full English emails either. I'll update my question. – vacip Jan 25 '18 at 14:41
  • This is NOT correct, as @kristoz mentioned and presented in a print screen - the same document can have text corrected in multiple languages, if added correctly. – Arnis Juraga Aug 26 '19 at 10:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.