0

I am trying to set up a ssh server on Linux through virtualbox on a Windows 8.1 (windows has wireless connection). I have installed openssh and got it running. I've set up rules for the inbound and outbound allowing port 22 on my windows firewall. Steps I used for port forwarding:

(Centurylink Modem Configuration) 1. Select device = 192.168.0.16
2. Starting port = 22
3. Ending port = 22
4. Protocol = TCP
5. Remote port = [All IP Addresses].

I have accessed ssh on a local network. I've went to https://www.yougetsignal.com/tools/open-ports/ and port 22 was open. When I tried to connect to root@my.external.IP:22 on Android JuiceSSH it returned:

"Connection Failed failed to connect to /my.external.ip (port 22): connect failed: EHOSTUNREACH (No route to host)

Do you want to retry?"

  • 1
    Please be more specific for this statement: " I've port forwarded port 22 to Virtualbox IP (192.168.0.16)" Also you should describe how your windows machine is connected to internet – Menion Jan 25 '18 at 16:08
0

I got it working. I shut down everything and rebooted the server and it worked. I guess the server couldn't change stuff while its running? Learned something new though, fun project.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.