125

Not too long ago, Google Chrome allowed users to delete specific autofill entries - either by going into their “Settings -> Autofill Settings -> Delete” the specific entries, or by going to the form you want to delete the autofill entry for, mousing over / pressing down on your keyboard and then pressing Shift+Delete.

Neither of these two methods appear to work any more.

Does anyone know how to delete specific autofill entries from Google Chrome?

Note: I don’t want to delete my passwords / manage passwords. Going to “Settings -> Advanced -> Passwords & Forms -> Autofill” settings doesn’t solve my problem.

Pressing Ctrl+Shift+Del and clearing autofill settings is not what I want; I want to delete specific autofill entries.

5 Answers 5

160

Hopefully I haven't oversimplified but I think there'll be enough to answer your question.

Step 1 - For example, click in the "Username" field/input box and press the down arrow (this will bring up a list of remembered "username" auto-fill entries)

Step 2 - Use the down arrow key to highlight the username (auto-fill entry) you want to delete

Step 3 - Press shift+delete, or shift+alt+backspace if you have a Chromebook

Done.

8
  • 2
    And I did read your post but I provided my answer because I JUST did it right before answering your question. I am using Chrome browser version 63.0.3239.140 on an updated Chromebook (not sure why shift+delete didn't work for you unless you have a Chromebook without a delete key and so it has to be shift+alt+backspace, fyi alt+backspace = delete). Feb 12, 2018 at 22:14
  • 2
    Do this for 100+ entries ...
    – Avatar
    May 21, 2019 at 5:02
  • 30
    It took some experimenting with the modifier keys, but I finally found that on a macbook, it's [SHIFT]+[FN]+[BACKSPACE]
    – daiscog
    Feb 6, 2020 at 10:13
  • 3
    Doesn't work for me. Any updates for chrome 80?
    – Yehuda
    Apr 22, 2020 at 7:09
  • 2
    This works, thanks. Why can't Chrome make it work like: right click on the option and delete?
    – John Smith
    Aug 30, 2020 at 22:25
72

For macOS:

Shift + Fn + Delete (backspace)

6
  • Worked for me, but my MBP has a Delete key, not Backspace.
    – user70848
    Sep 15, 2018 at 2:06
  • Doesn't work on saved passwords =/
    – Pysis
    Nov 4, 2019 at 14:56
  • This is the only thing that works on Mac. Shift+Delete does not work on Mac Feb 9, 2020 at 19:27
  • 2
    Apple calls their "Backspace" key "Delete". Chrome still thinks of it as Backspace. On a Mac, Fn+Delete is "Forward Delete", which Chrome thinks of as the regular Delete key. So in a way, this is still Shift+Del, since Del = Fn+delete. I'm worried my explanation is confusing, but there you are. Feb 9, 2021 at 22:35
  • Worked for me. Thanks. Sep 8, 2021 at 18:23
11

Based on Brian R. Quigley method:

After clicking inside any auto fill field, you can hover by mouse on the desired entry then press Shift+Delete.

2
  • Just what I was looking for. This works like a charm on Chrome in Windows. Mar 12, 2021 at 8:03
  • This one works on Linux.
    – MInner
    Jul 13, 2021 at 15:51
5

On a mac, adding the Fn. key is only needed when you have the short keyboard, in the long full sized keyboard you can use Shift+delete keys same as in windows the reason for this is the default del key in the short keyboard is actually a backspace key, but pressing Fn key will turn it to Del

If it’s bookmarked, it won’t be deleted when you press fn+shift+delete. You have to delete the bookmark first.

1
  • Excellent answer!
    – skiabox
    Feb 11, 2019 at 22:04
-1

It looks to me like google has moved the chrome settings around. I'm not sure if this has to do with your issue, but I just deleted a specific autofill entry by going to settings > passwords (under people just below sync). I also turned off "offer to save passwords" because that was the source of my pain. Random people who logged into amazon in my case, were cluttering my AWS login autofill...

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.