3

My son has his own account on my computer (mine is administrator, his is a normal user). For some reason I cannot log in using his account anymore. (Edit: I see now how this may sound like I was trying to sneak in. What I meant to say is that he's unable to log in and I'm trying to solve that problem). More precisely the problem is this:

  • I select his username and enter his password
  • the credentials are accepted because I see his desktop, though only for a split second
  • then it redirects to the photo that Windows shows before logging in

If I then log in as myself and open Task Manager, I can see in the Users tab that there is in fact a session for him (status=disconnected). Also, on the Details tab, I see a number of 'standard' processes running under his account.

I noticed the he has a process called lockapp.exe running. I don't have this program running under my account. I tried killing that process and logging in as him again. The same problem occurs but the lockapp.exe process is not recreated for him.

Some more info:

  • I tried making him admin temporarily and log in as him using Remote Desktop from my laptop. More or less the same problem although now it just hangs.
  • I have RDPWrap installed. That's a program that allows for multiple accounts to connect using Remote Desktop simultaneously. I've uninstalled it but that didn't solve the problem.
  • MalwareBytes and a search for lockapp.exe's SHA-1 on Google come up clean
  • Windows defender reports no problems
  • Currently running Windows 10 Version 1709 for x64-based Systems (KB4058702)

Does anyone have an idea what could be going on.

  • Forget about "clean", that "lockapp.exe" sounds like exactly what's causing this. Find out what program this goes to. I'd bet, it is related to, or is owned by, RDPWrap. You said that you, "uninstalled" it, but I doubt if you uninstalled all the components, OR orphaned scheduled tasks, and likely not for that user, since you can't log in as that user. I think you have all the clues there. Now, find out what's being started in task scheduler and stop it. – DaaBoss Jan 27 '18 at 14:22
  • 2
    Also, you may want to talk to your son about this. If I were him I and I suspected you would be checking my account, rather than ask you about it, as a child, I would do something so you would not get in, but I could. There's a big chance if this is true and you just ask him, he'll burst out in laughing and then ask you: so, you couldn't get in huh? – LPChip Jan 27 '18 at 14:26
  • Kids will always be resourceful, especially when they feel their privacy is bypassed ;) Try safe mode and see if the same process runs. – DankyNanky Jan 27 '18 at 16:54
  • About privacy: I agree with all that. But here's some context. My son is 9 years old. He uses the password that I chose for him. He's aware that I am trying to solve his problem. He has no accounts yet at any web site and he has zero private content on this machine. – mgr326639 Jan 27 '18 at 17:36
  • @mgr326639 Not trying to be rude mate, just a little bit of banter. Did you attempt safe mode? Perhaps try safemode with command prompt and stop that file starting on boot. – DankyNanky Jan 27 '18 at 18:05
0

Here is how I fixed one like that. Bite the Bullet

Open up a CMD window in Administrative Mode
rendir c:\users\username username.bat
Delete the user through Control Panel.
Recreate the user

Then you can figure out how you want to deal with the previous files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.