25

On my Mac, Using Command+Tab to switch windows seems to work only sometime.

Other posts suggest pressing OPTION key and it works.

Though it is not clear to me why Command + TAB works only sometimes to switch the windows and is there a way to fix this? Am I missing something?

I am on MacOS High-Siera 10.13.3

  • I have same issue. When you command+tab to say chrome, intellij or skype, it sometimes jumps to that running app, sometimes does nothing. Its fairly random. There are some apps, such as slack, that it never switches to, you always have to click on its icon in the bottom to switch to its open window (or close the windows above it). Its frustrating as a developer that there is no reliable way to switch running apps. – John Little Feb 8 '19 at 8:09
  • Mac is not okay – lakesare Jun 30 at 17:32
34

Open Terminal and type

killall Dock

Hit return.

Your Dock will disappear for a second and then reappear but open apps will not be affected.

Try Cmd+Tab now.

| improve this answer | |
  • Wow, it actually worked! Thx, it saved my day. – Nikola Schou May 5 at 19:27
  • Not working for me in Catalina OS – madhu131313 Jul 22 at 14:12
  • It's working, thanks, but do I've to do that every time it's not working! isn't there a permanent solution?. – Yehia Aug 14 at 13:48
8

On MacOS you would get best switching experience if you DO NOT MINIMIZE your windows.

Command + Tab : to switch to windows that are not minimized

Command + Tab followed by Option : to switch to a minimized window

When I asked this question, I was a newbie MacOS user with years of Windows experience.

Now, it feels like MacOS design is optimized towards leaving your windows open (irony)

| improve this answer | |
  • By "Alt" do you mean "Command"? "Alt" and "Option" are the same key on a mac (although not all keyboards show this). – CupawnTae Jul 20 '19 at 9:40
  • 1
    Recently moved to MacOS from Windows. Can't believe how unintuitive the window mechanism is in MacOS. – Pirate X Jul 15 at 6:26
7

If you're running a Virtual Machine manager like VirtualBox sometimes it seems that an open Virtual Machine window grabs the key (which is often used switch from VM keyboard capture mode).

In this case you'll need to bring the VirtualBox Console window up (e.g. using the Dock bar) and tap the key again and it should release it properly.

| improve this answer | |
2

Do you use any remote controlling software such as Anydesk or TeamViewer?

In my case, they were grabbing certain keyboard inputs.

Close them all if any other answers don't work.

| improve this answer | |
1

Command+Tab allows you to switch between open applications (whereas Command+` allows to switch between open windows within an application).

If these options are not working properly, the Modifier Keys options may have been remapped.

These options are found in System Preferences - Keyboard - Modifier Keys. enter image description here

| improve this answer | |
1

Use AltTab, it is the exact replica of windows functionality of Alt+ Tab. Takes care of both minimised/maximised window

| improve this answer | |
0

It just happened to me on my MacBook Pro.

Turns out, I've been using HyperSwitch to manage app-switching and windows-switching, and HyperSwitch recently expired (not sure why). After installing new version of it, cmd-tab is back to working order.

| improve this answer | |
  • What version specifically did you install? Edit your answer with this information – Ramhound Jul 18 '19 at 19:28
  • @Rambound - I think the specific version is immaterial. The key is, when HyperSwitch detects there is a newer version, and possibly after some days of using older version (or other factors), the current/old version gets blocked, causing Cmd-Tab to not work at all. – Wayne Jul 19 '19 at 20:18
0

As @Custom Soundtrack mentioned, killall Dock should bring those seldom used app back to picture.

As @Amol suggested, avoid to minimize the window to get to more consistent switching experience. One alternative is hiding your window using Command+H. However, unlike minimize, this applies to all the windows of the front app.

If you do minimize you window and still want to keep your hands on keyboard, Command + window number should bring back the main window. Currently Slack is 1, iMessage is 0.

But lots of app don't have a corresponding window number. In this case, there's a trick mentioned in this post. Basically after you Command+tab. Release only tab button. Keep pressing Command and press Option. Now pressing Option release Command button, the windows will be maximized

| improve this answer | |
-1

My experience is that command + tab works if the current window isn't maximized. If it is (i.e., fit to the screen), command + tab switching doesn't work.

| improve this answer | |
  • This is not related to window being maximized – Amol Oct 10 '19 at 22:10
  • @Amol one of the situations where command + tab doesn't work is when the current window is maximized; so it's related to command - tab issue and a specific case under that... – Krishna Oct 11 '19 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.