2

I am daily using several languages.
It seems that Microsoft Edge supports spell check: red lines appear under words detected as not correctly spelled (actually: non-English words), and the software even attempts to correct the spelling of the words typed.
This is irritating to have a word being modified because Edge does not understand other languages.

How can I add a change the spell check language?
Alternatively, how can I disable the (broken) auto-correction feature?

  • Why is auto-correction "broken" if it is picking up non-english words? It should do that... Adding a second language sounds like the most sensible option here otherwise you will not have a spell-check or grammar at all... – Solar Mike Jan 29 '18 at 6:32
3

You can't change this on the fly, but you can change this as often as you like. There's two ways to get to this menu

  1. Open Internet Options from the Control Panel or from Internet Explorer (Tools > Internet Options).
  2. In the General Tab, click the Languages button at the bottom.
  3. Click Set Language preferences.

Or:

  1. Go to Settings in Windows 10.
  2. Click Time & Language.
  3. Click the Language side menu option.

Then, click Add a language, or if you've already added a language, you can re-order the list of languages you have chosen so that your preferred language is on top.

From here you can add whichever language you want. The reason I say you can't do this on the fly is that Microsoft Edge will need to be restarted before it will detect your changes.


To disable spellcheck, go to Settings, type "spell check" (without quotes) in the search bar and hit Enter, and then you will see the option to disable highlighting or autocorrecting of misspelled words. Again, Microsoft Edge will need to be restarted before it will detect your changes, if you have it open when you make these changes.

  • To change the language or add another language, why are you suggesting users go through internet options? When I tried that, it just routed to the devices--> typing. Also, disabling autocorrect does not always work (at least not in my case) – user3386170 Jul 5 '18 at 1:18
  • 1
    @user3386170 When I wrote the answer the steps listed were how you had to do it. It is highly possible (and quite probable) that Microsoft has completely changed the settings involved/steps to accomplish this since then. Every update to Windows 10 has made significant changes. – TylerH Jul 10 '18 at 14:36
1

Microsoft Edge does not support multiple spell-check dictionaries that are switchable on-the-fly. You need to change the keyboard language for that and also restart the browser, which is sort of useless as most people only have one connected keyboard.

This is a common complaint which Microsoft simply fails to understand, not understanding at all the needs of users dealing with multiple languages in their daily life.

Until Microsoft does something about this lack, the only solution is to use another browser.

1

Edge underlines all spelling errors in the 5 languages that I aggregated. But it only gives a correction suggestion for errors in the keyboard language. In Windows (10) documents I have some paid language packs installed and there I'm getting corrections.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.