0

I have dual boot Windows 10 and Ubuntu 16.04 LTS on my Thinkpad. Recently I am experiencing strange issues on my laptop. I'll list the issues. I have experienced all of them in past 2 weeks.

With Ubuntu

  • While using, it randomly freezes with no mouse pointer movement. A hard reboot is then required.
  • On booting it shows:

/dev/sda6 contains a file system with errors, check forced. /dev/sda6: Inodes that were part of a corrupted orphan linked list found.

/dev/sda6: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY. (i.e., without -a or -p options) fsck exited with status code 4 The root filesystem on /dev/sda6 requires a manual fsck

Busybox v1.22.1 (Ubuntu 1:1.22.0-15ubuntu1) built in shell (ash) Enter 'help' for a list of built-in commands.

(initramfs) _

  • While using internet, browser tabs starts crashing immediately.
  • On booting, It gets stuck on tty menu.
  • On booting, it gets stuck on purple screen. A hard reboot is then required.

With Windows

  • Shows blue screen errors with different error codes before reaching login screen and restarts.

  • While using, shows blue screen error and restarts.

There is definitely some hardware problem involved. I tried running various HDD tests but it passed all of them. I am guessing there is some problem with the laptop fans. It is also generating immense heat.

URGENT help required. Thanks.

  • I think you've answered your own question... you may have a hardware fault/imminent failure on the horizon... we can't fix this without someone looking at the hardware... have you tried using, say, compressed air to clean the heatsink and vents? It may need dismantling to clean/re-paste the heatsink to the CPU.... – Kinnectus Jan 30 '18 at 7:57
  • Prepare a bootable flash disk with Ubuntu on it (or some other flavor of Linux that can be booted without installing). Check hard disk's SMART attributes. Most likely your HDD is dying. – gronostaj Jan 30 '18 at 7:58
  • @Kinnectus No, I didn't try dismantling it yet. I'll see if I can get that done. Thanks. – Kanishk Saxena Jan 30 '18 at 8:17
  • @gronostaj Ok, I'll try to do that. But I think my HDD is fine as it passed all the tests I performed on it. Thanks. – Kanishk Saxena Jan 30 '18 at 8:18
1

I would suggest following:

  1. Disassemble, clean-up and reassemble your CPU compartment (RAM, HDD, CPU sink, Fan, SMPS etc. Try swapping with similar units if you feel necessary.
  2. Try running Windows in safe mode and see if similar event(s) occur. If not there might be chances of corrupt Linux installation and/or driver incompatibility issues.
  3. If you have installed Ubuntu after having Windows installed on your system or vice versa, try reformatting the new drive you've created during secondary installation and see if this fixes issues with former OS and reinstall the OS.
  4. This might be Lenovo specific issue as well. So consult a Lenovo expert if the above steps fails.
  5. Lastly it could be hardware failure issue so replacement of the faulty part might fix the issue.

Personal Reference: I had installed Ubuntu 16.04 LTS on my Acer Aspire laptop in dual boot configuration after Windows 10. It is mostly working fine except while using Ubuntu the laptop shuts down when CPU temperature goes above 80-85 ° C while I didn't notice this in Windows. My laptop speakers also got busted as soon as I started using Linux! Something related to how it drives the hardware.

Also installed same configuration on a friend's Sony laptop and he was unable to boot up after some time. So I think it might be related to hardware specific configuration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.