1

I do have a Linux Mint 18.3 VM hosted on a window 10 machine.

My VM can not boot when 3D acceleration is set into the virtualbox machine settings. It stays stuck on an empty command line screen.

If I hit alt-f4 to go into command line mode and try to startx I get the following error:

xf86EnableIOPorts: Failed to set IOPL for I/O.

After looking around, I found a work-around to start the desktop from there. As superuser, I need to chmod u+s /usr/bin/xinit and startx again and it works.

However, each time I restart the machine, I still have to follow the steps above or the same error persists.

Being not very knowledgeable in linux inwards, I wondered it someone could infer a permanent fix from my temporary one.


EDIT: I just re-created a VM from scratch on a new disk, with the same setup. I can confirm that it was not specific to the other VM since I have the same issue. Still no 3D acceleration.

I am wondering, why, if there is a workaround, VirtualBox folks have not fixed this already.

1 Answer 1

1

This may be your problem: The Guest Additions which come with VirtualBox 5.2.6 and 5.1.32 do not work properly on Linux guests with 3D enabled. There are updated versions available here: https://www.virtualbox.org/wiki/Downloads

2
  • Indeed you are right. It did the trick. I didn't notice that line on the download page. It all works with 5.2.7. Thank you sir :) Jan 31, 2018 at 8:54
  • You're welcome, I knew about this because I was on that site just the other day.
    – Tim
    Feb 2, 2018 at 3:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.