3

I've just received my new laptop (Asus Zenbook), and installed Ubuntu 17.10 on it.

I installed Chromium on it (Version 63.0.3239.132), but it could not access my webcam at all. I tried with appear.in, hangout, meet, and all the others, but the result is always the same : it doesn't ask me at all to allow any webcam. Even if I force it with the left "secured" button, it doesn't change anything. In appear.in, it says "We can't detect a camera. Try connecting a camera to join the conversation".

When I use other softwares, like Firefox or Cheese, it works just fine.

All the posts I found are to allow access to a detected camera, but I can't find anything to help chrome detecting the cam :)

The problem occurs with HTML5 based site, so it is not flash related.

3 Answers 3

10

Thanks to Nikita to point me at the snap install. I found on this launchpad the way to connect the camera to a snap install. It works perfectly

$ sudo snap connect chromium:camera :camera
2

My sister had the same problem.

It looks like Chromium is now available as an Ubuntu Snap, maybe that caused the problem. We removed the Chromium Snap via the Ubuntu Software Center, and installed official Google Chrome Ubuntu browser.

To do this, go to chrome.google.com, download a .deb file, then open your terminal and run sudo dpkg -i path/to/downloaded.deb. It will fail with error (probably), so finish your installation with sudo apt-get -f install.

After that you will be able to access Google chrome using google-chrome command in launcher (Alt + F2).

Also we switched to Xorg instead of Wayland to make sure the screen can be shared in Hangouts. But this is probably another problem, but you may want to try, if first recommendation won't help.

1
  • Thanks a lot ! Indeed it works with chrome stable. But I really would like to have it works with Chromium. I will search in the direction of this Ubuntu Snap thing...
    – JR Utily
    Commented Feb 6, 2018 at 17:44
1

I had a similar problem with Opera Browser Version 72.0.3815.378; I solved it by accessing Settings > Applications > Opera (or your browser) > Use your camera (on/off) - Set it to on. I hope this helps to solve this problem for someone who is having the same issue.

Allow camera to work on opera, or other browsers

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .