0

I'm trying to use MkDocs and when I run:

mkdocs serve

I get the following output:

INFO    -  Building documentation...
INFO    -  Cleaning site directory
[I 180130 17:24:42 server:283] Serving on http://127.0.0.1:8000
[Errno 10048] Only one usage of each socket address (protocol/network address/port) is normally permitted

I can't find the way what other services are using/running on that ip/socket. Any help much appreciated.

  • What operating system? – Twisty Impersonator Jan 31 '18 at 1:19
  • windows, thanks. I've already figured it out, virtualbox was causing the problem. – George Garchagudashvili Jan 31 '18 at 2:03
  • 1
    Please post an answer if possible. Otherwise please close the question since it won't get other meaningful answers given you've solved it. – Twisty Impersonator Jan 31 '18 at 2:04
2

I've found a solution:

  1. Run resmon for resource monitor dialog
  2. On Network tab search for Listening ports section
  3. Look for the one taking 8000 port (in my case it was a virtualbox instance)
  4. Turn it off and it will work.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.