-1

I am using VirtualBox v5.2.4. When I set metasploitable to NAT/NAT Network/Host-only adapter I cannot reach it when I ping from Kali. However, when I set it to bridged, I am able to reach it. I do understand using bridged is a security risk.

Can someone please tell me what I am doing wrong?

By the way, I already went to File >>Preferences >> Network >> Add a NAT Network and changed the IP to 192.168.xx.xx.

Thanks.

  • It's unclear what your host is, what your guests are and what your network configuration should actually look like. It might be a good idea to read the VirtualBox manual on networking. – Seth Feb 1 '18 at 6:51
0

I figured out the issue, just in case some newbie like myself encounters same problem... my host only configuration wasn't right. I was unable to configure the DHCP server and adapter following the instructions I found elsewhere on this internet because in Virtualbox 5.2.4 for windows, the host only settings are under "Global Tools" and not File>>Preferences. After the configuration, I set both Kali and Metasploitable to Host Only adapter and everything works as expected now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.