1

My main system (Windows 7 UEFI) is on a SSD. I have a 2nd GPT hard drive I use for backup that is not plugged to the computer.

After unplugging the SATA cable of the SSD, I installed Windows 10 UEFI on the 2nd HD so if my SSD fails, I still have a functioning system I can use in the mean time.

The install went fine. But now when I unplug the HD and plug the SSD, Windows 7 won't boot. I think the Windows 10 install messed with the Windows Boot Manager in the BIOS and it prevents me from booting.

I have an image backup of the W7 boot partitions so I think I can restore everything back to normal... except that when I'll do that, Windows 10 won't boot.

So the question is: how can have on the same machine (i7 2600K, Asus P8P67 B2) 2 UEFI Windows (7 + 10) on 2 different drives that are not plugged at the same time?

19
  • It is certainly possible when you install each system with the other drive disconnected, though you will need to switch the boot disc when you switch boots. You should be able to repair the drives individually with each connected one at a time in order to make them separately bootable.
    – AFH
    Jan 31, 2018 at 17:01
  • Windows 7 (SSD) and Windows 10 (HD) were installed separately (with the other drive unplugged). When you say "switching the boot disk", do you mean switching the SATA cable? Also, how can I repair the drives individually? Thanks for the pointers. Jan 31, 2018 at 17:10
  • No, I meant changing the hard disc boot priority in the boot settings. You shouldn't need to make hardware changes. I have a system with independent boot sectors on three different drives, and I have not managed to make either of them cross-boot from another drive, so I need to switch disc boot priorities.
    – AFH
    Jan 31, 2018 at 17:20
  • Ok I understand now. I actually tried that but when I force the BIOS/UEFI to boot on my SSD (Win7), it tries for a sec, then goes back to the UEFI/BIOS. It may be because it tries to boot in "MBR mode" (don't know what it's really called, I mean not UEFI)? Jan 31, 2018 at 17:32
  • That's probably called Legacy Mode in the UEFI/BIOS boot settings: you will need to switch this, as well as the boot priority.
    – AFH
    Jan 31, 2018 at 17:41

0

You must log in to answer this question.

Browse other questions tagged .