My library's OPAC (online public access catalog) website doesn't currently use HTTPS. Trying to view it with a secure connection 'crashes' it regardless of browser. However once I accidentally tried to visit the site via HTTPS and now it automatically tries to serve me the secure version no matter what I do.

I've had the same problem in Chrome for a while, and while I can use the solution presented in this similar question and it will fix it for a little while by my next session the HTTP to HTTPS redirect is back in chrome.

For that reason I've been using Firefox mostly until today when I accidentally pasted an HTTPS link to the website into Firefox now Firefox will only serve the HTTPS version as well.

  • Maybe this might help a bit, about:config - browser.urlbar.autoFill (false) ? – Tech-IO Feb 1 '18 at 17:03
  • @Tech-IO Nope... – aslum Feb 1 '18 at 19:53
  • Or maybe using an add-on e.g. addons.mozilla.org/de/firefox/addon/noredirect But you may find an add-on by your self, just search for no redirect or no redirection. – Tech-IO Feb 1 '18 at 19:58
  • have you tried to clear everything (ctrl-shift-del)? – Putnik Feb 2 '18 at 7:06
  • The redirect is returned by the server. You can't control that from the client. – Adrien Feb 2 '18 at 21:55

Exit Firefox and edit the file


Delete the line with your domain in it. Then restart Firefox. That will stop the redirection. That file is like Chrome's chrome://net-internals/#hsts.

The xxx and 999 will be random letters and numbers. The path is for Windows. Use Menu > Help > Troubleshooting Information > Profile Folder to find where your profile is located. In Linux the file is

| improve this answer | |
  • 1
    Wow, very useful. Curious, how you were able to figure out that this is where such is stored? – Coldblackice Jul 10 '19 at 22:46
  • 1
    @Coldblackice I probably knew where Firefox settings were and used find AppData/Roaming/Mozilla/Firefox/Profiles -type f | xargs grep domain.com in CygWin bash shell. – Chloe Aug 16 '19 at 0:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.